Synology DSM Sicherheitsberater: Der Standardwert des SSH Ports wurde nicht geändert

  • Hallo zusammen,

    heute morgen begrüßt mich mein Synology NAS mit der folgenden Meldung des Sicherheitsberaters:

    Schwere: Hoch

    Beschreibung: Der Standardwert des SSH Ports wurde nicht geändert

    Details: Die Änderung des SSH-Ports verhindert, dass nicht autorisierte Benutzer ihr System über den Standardport 22 angreifen.

    Empfohlene Aktion: Gehen Sie zu Systemsteuerung > Terminal und SNMP..... Ändern Sie auch die SSH-Einstellung für die SSH Clients.


    Ich versteh nur Bahnhof. Könnt ihr nachvollziehen, was mir der freundliche Sicherheitsberater damit sagen möchte? Und was hat es zur folge, wenn ich die vorgeschlagenen Korrekturen vornehmen. Keine Ahnung ob ich irgendwelche SSH-Clients habe.....

    MfG
    Reelyator


    Homecinema: Marantz SR7011 + MM7025 // UHD: Cambridge Audio CXUHD // Streamer: Cambridge Audio Azur 851N // Lautsprecher: Dali HELICON MKII in 7.1.4 Konfiguration // Beamer: Panasonic PT-AE3000 // TV: Panasonic TX-58DXW904 // Synology DS3617xs NAS

  • Hallo, entweder änderst du den Port für den SSH Port auf einen anderen als 22 oder schaltest du den Check für einen benutzerdefinierten SSH Port einfach ab.


    Ich habe den SSH Dienst deaktiviert und schalte diesen nur wenn notwendig kurzfristig aktiv, danach wird der wieder gestoppt. Daher meldet der Sicherheitsberater den Port bei mir auch nicht.


    Zum kompletten Deaktivieren müsstest du im Sicherheitsberater unter Erweitert eine benutzerdefinierte Checkliste für die Sicherheitsrichtlinie erstellen...


    LG

    T.

  • Danke T.!

    Wofür wird der SSH Dienst denn überhaupt benötigt. Soweit ich das verstehe ist das auch nur ein Netzwerkprotokoll, korrekt? Da ich von Kodi per SMB auf meine Medien zugreife, würd ich mal vermuten, das ich den Dienst garnicht brauche. Ich hab aber leider keine Ahnung, wie meine Musik-Player (Marantz AVR/Heos, Cambridge Audio Azur851N, Raumfeld) auf die Medien zugreifen...

    MfG
    Reelyator


    Homecinema: Marantz SR7011 + MM7025 // UHD: Cambridge Audio CXUHD // Streamer: Cambridge Audio Azur 851N // Lautsprecher: Dali HELICON MKII in 7.1.4 Konfiguration // Beamer: Panasonic PT-AE3000 // TV: Panasonic TX-58DXW904 // Synology DS3617xs NAS

  • Auszüge aus WIKI:

    SSH ermöglicht eine sichere, authentifizierte und verschlüsselte Verbindung zwischen zwei Rechnern über ein unsicheres Netzwerk. Dadurch dient es unter anderem als Ersatz für die Vorgänger rlogin, telnet und rsh; diese übertragen jeglichen Netzverkehr, darunter auch die Passwörter, unverschlüsselt.

    Sowie Putty, damit kannst du eine Verbindung zum NAS herstellen und Befehle ausführen.


    Jeder NAS Besitzer sollte entweder den Port ändern, oder das Protokoll deaktivieren.Da man es nie braucht.

    Das ändern der Portnummer am NAS geht nur über z.b. Putty.

    Solange du an deiner NAS keine Portweiterleitung (Internet) hast würde ich ihn deaktivieren.

    Du musst dir vorstellen je mehr Ports du öffnest um so größer ist die Gefahr ein Tummelplatz für Script Kidies zu öffnen. Ein Portscan ist schnell durchgeführt.

    Panasonic TX 58DXX789
    AVR: Yamaha RX V 631 Multicast
    Kodi 18.7 (Leia) mit Skin ACE 2.0

    HiMedia Q10 Pro + 9x8 TB WD + Int. 8 TB WD Script @messer, CFW 2.14 by @moere22

    Synology DS 1618+ mit 6x 8 TB WD RED
    Synology DS 1618+ mit 6x 10 TB Ironwolf

    Synology DS 1618+ mit 6x 12 TB Ironwolf
    SSD M2 Sata 256 GB+ Leergehäuse

  • Danke T.!

    Wofür wird der SSH Dienst denn überhaupt benötigt. Soweit ich das verstehe ist das auch nur ein Netzwerkprotokoll, korrekt? Da ich von Kodi per SMB auf meine Medien zugreife, würd ich mal vermuten, das ich den Dienst garnicht brauche. Ich hab aber leider keine Ahnung, wie meine Musik-Player (Marantz AVR/Heos, Cambridge Audio Azur851N, Raumfeld) auf die Medien zugreifen...

    Schalte SSH doch mal einfach ab:


    In der Weboberfläche auf die Systemsteuerung, dann auf „Terminal & SNMP“, dort deaktivierst du die Checkbox „SSH Dienst aktivieren“


    Wenn dann noch alles funktioniert (wovon ich mal stark ausgehe), dann lass das so.


    Ansonsten den Dienst einfach wieder aktivieren, dann musst du den Weg über Warnung deaktivieren im Sicherheitsberater gehen...


    Bzw. den Port könntest du übrigens auch einfach via Weboberfläche ändern, ist gleich unter der Aktivieren Checkbox.


    LG

    T.

  • ..Danke für die Nachhilfe. Ich hab ihn jetzt deaktiviert. Bisher sehe ich keine Nachteile und der Sicherheitsberater gibt nun auch Ruhe.

    MfG
    Reelyator


    Homecinema: Marantz SR7011 + MM7025 // UHD: Cambridge Audio CXUHD // Streamer: Cambridge Audio Azur 851N // Lautsprecher: Dali HELICON MKII in 7.1.4 Konfiguration // Beamer: Panasonic PT-AE3000 // TV: Panasonic TX-58DXW904 // Synology DS3617xs NAS

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!