DVD-ISO-Wiedergabe über Kodi VideoPlayer funktioniert nicht (richtig)

  • Hallo zusammen,


    ich habe ein Problem mit meinem Himedia Q10 Pro mit der Custom Firmware 2.1.4. Immer wenn ich eine DVD-ISO über den Kodi-VideoPlayer starte, gibt es einen etwa eine Sekunde andauernden unangenehmen lauten Ton ("hochfrequentes Rattern"). Der Ton hört sich an wie eine kaputte CD und variiert. Bei einigen ISOs kommt der Ton immer wenn eine neue Videodatei der ISO abgespielt wird (vor jedem Logo, vor dem Hauptmenü, nach dem drücken von Film starten, usw.). Außerdem blinken die Untertitel (sind kurz weg, dann wieder da und das die ganze Zeit im Wechsel). Beides leider sehr unangenehm beim schauen. Nach kurzer Abspieldauer pausiert die Wiedergabe und lässt sich nicht fortsetzen (Zeit läuft weiter, aber das Bild bliebt eingefroren). Sämtliche getesteten DVD-ISOs lassen sich über andere Geräte fehlerfrei abspielen. Bisher habe ich nur Blu Rays und .mkv abgespielt und dachte das mein Himedia fehlerfrei läuft.

    Hat jemand ähnliche Erfahrungen gemacht oder kennt eine Lösung?


    Android Version: 7.0.0 API Level 24 (kernel: Linux 3.18.24_hi3798cv2x)


    Beste Grüße

    LiQuid120

    6 Mal editiert, zuletzt von LiQuid120 () aus folgendem Grund: Rechtschreibung und Ergänzung.

  • Welche KODI Version ist installiert und wurde diese bereits mit einem Online Update versehen.

    Gruss Lony


    Mediaplayer: ZIDOO Z1000Pro, ZIDOO Z9x, ZIDOO X9s, UGOOS AM6 Plus, VERO 4K+

    TV :Sony KD-75XD9405, LG 49SM8500PLA

    SAT-Receiver: Vu+ Uno 4K SE mit VTi 14.0.5

    AVR Denon X3600H

    SOUNDSYSTEM :Teufel System 6 THX 5.2.2

    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED, DS216Play - 2 x 2TB WD RED

  • LiQuid120

    Hat den Titel des Themas von „DVD-ISO-Wiedergabe über Kodi hat Störgeräusche“ zu „DVD-ISO-Wiedergabe über Kodi VideoPlayer funktioniert nicht (richtig)“ geändert.
  • Ok 18.3 die ist leider schon Asbach.


    Bitte deinstallieren und dann per Stick die neue KODI 18.7 installieren.


    Download gibt es hier https://kodi.tv/download


    Bitte unter Android die 32 Bit Version downen , rauf einen Stick und dann installieren von Stick.


    Testen und bitte wieder melden.

    Gruss Lony


    Mediaplayer: ZIDOO Z1000Pro, ZIDOO Z9x, ZIDOO X9s, UGOOS AM6 Plus, VERO 4K+

    TV :Sony KD-75XD9405, LG 49SM8500PLA

    SAT-Receiver: Vu+ Uno 4K SE mit VTi 14.0.5

    AVR Denon X3600H

    SOUNDSYSTEM :Teufel System 6 THX 5.2.2

    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED, DS216Play - 2 x 2TB WD RED

  • Habe ich gemacht. Leider tritt der Fehler auch unter 18.7 auf.

    Wie ist denn die Soundanbindung, AVR ?, Soundbar ? oder direkt von TV Boxen ??

    Gruss Lony


    Mediaplayer: ZIDOO Z1000Pro, ZIDOO Z9x, ZIDOO X9s, UGOOS AM6 Plus, VERO 4K+

    TV :Sony KD-75XD9405, LG 49SM8500PLA

    SAT-Receiver: Vu+ Uno 4K SE mit VTi 14.0.5

    AVR Denon X3600H

    SOUNDSYSTEM :Teufel System 6 THX 5.2.2

    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED, DS216Play - 2 x 2TB WD RED

  • hochfrequentes Rattern

    Also meiner Meinung nach können Geräusche nur von mechanischen Komponenten kommen z.B. wie Festplatten.

    Ich würde hier eher auf einen Defekt der angeschlossenen Festplatten schließen.

  • Das Geräusch ist definitiv Teil des Audiosignals und kommt aus den Lautsprechern. Das macht es so unangenehm (ist sehr laut und kommt unerwartet). Es hat mit der Software des Kodi VideoPlayers zu tun. Warum keine Ahnung. Über den Wrapper läuft alles normal, leider kann dieser keine DVD-Menüs abspielen. Ich habe jetzt als Workaround die VLC Player .apk installiert und hier lassen sich die selben ISO-Dateien fehlerfrei abspielen. Über die playercorefactory.xml lässt sich VLC auch direkt in Kodi einbinden.


    Update: Der VLC-Player scheint auch nicht so optimal zu laufen. Es gibt Mikroruckler während der Wiedergabe und die Menüs werden zwar angezeigt, aber funktionieren nicht vollständig (im Gegensatz zur Windows Version von VLC). Aber immerhin bricht die Wiedergabe nicht ab. Am besten arbeitet immer noch die Wiedergabe über der Wrapper. Schade das dieser keine Menüs anzeigt. Gibt es eine alternative Version des Wrappers die DVD-Menüs supported?


    Einbindung von VLC in Kodi:

    Speicherpfad: \\192.168.xxx.yyy\share\sdcard\Android\data\org.xbmc.kodi\files\.kodi\userdata\playercorefactory.xml


    <player name="VLCPlayer" type="ExternalPlayer" audio="false" video="true">

    <filename>org.videolan.vlc</filename>

    <args>--fullscreen "{1}"</args>

    <hidexbmc>true</hidexbmc>

    <playcountminimumtime>120</playcountminimumtime>

    </player>



    Lony

    Der Sound läuft direkt über HDMI zum Fernseher ohne AVR. Zwischendurch war auch der AVR angeschlossen - auch hier die Störgeräusche. Allerdings sind diese über den AVR so laut, dass ich den Media Player lieber direkt an den TV angeschlossen habe.


    Grüße

    LiQuid120

  • Gibt es eine alternative Version des Wrappers die DVD-Menüs supported?

    Nein es gibt keine Alternative, da der Wrapper elementar nicht für das Menu verantwortlich ist, sondern immer der native SystemPlayer, so dann eben der Himedia SystemPlayer. Wenn kein Menu erscheint, dann bitte das alles mal im Himedia Mediacenter nachstellen und schauen, ob es dort auch der Fall ist.


    <args>--fullscreen "{1}"</args> ist eine Anweisung aus der Benutzung mit Windows heraus, dieses zwingt den VLC von vorn herein in einen Fullmode Picture. Dieser Parser ist aber unter Android völlig unüblich, da es nicht notwendig ist, der VLC läuft immer im Vollscreen. Entsprechender Aspect wird nur einmalig angepasst.

    Der Sound läuft direkt über HDMI zum Fernseher ohne AVR. Zwischendurch war auch der AVR angeschlossen - auch hier die Störgeräusche. Allerdings sind diese über den AVR so laut, dass ich den Media Player lieber direkt an den TV angeschlossen habe.

    Welche Soundeinstellungen sind unter KODI getätigt worden, wurde beides probiert (Passthrough sowie auch Stereo) und ist das Problem bei beiden Einstellungen vorhanden.


    Wie gesagt, bitte mal das DVD Menu mit dem Mediacenter verifizieren, geht es da, dann schauen wir mal weiter.

    Gruss Lony


    Mediaplayer: ZIDOO Z1000Pro, ZIDOO Z9x, ZIDOO X9s, UGOOS AM6 Plus, VERO 4K+

    TV :Sony KD-75XD9405, LG 49SM8500PLA

    SAT-Receiver: Vu+ Uno 4K SE mit VTi 14.0.5

    AVR Denon X3600H

    SOUNDSYSTEM :Teufel System 6 THX 5.2.2

    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED, DS216Play - 2 x 2TB WD RED

  • Die Untertitel flakern aber leider immer noch.

    Wenn Du mal irgendwo ein Schnipsel davon uppen könntest, dann würde ich mir das mal anschauen, ob da bei mir auch FlickerFlicker ist ;-)

    Gruss Lony


    Mediaplayer: ZIDOO Z1000Pro, ZIDOO Z9x, ZIDOO X9s, UGOOS AM6 Plus, VERO 4K+

    TV :Sony KD-75XD9405, LG 49SM8500PLA

    SAT-Receiver: Vu+ Uno 4K SE mit VTi 14.0.5

    AVR Denon X3600H

    SOUNDSYSTEM :Teufel System 6 THX 5.2.2

    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED, DS216Play - 2 x 2TB WD RED

  • Ok das Flicker Flacker sehe ich, ist unschön, um so trauriger ist, das hier nicht mal einer in der Lage ist, mal zu schauen , ob er das gleiche Problem hat.


    Ich habe mir mal die Mühe gemacht und geschaut, was denn nun bei einer ISO sowie auch bei einer DVD mit VZ passiert, ich kann das Problem bestätigen, bei mir gibt es auch dieses Flicker Flacker Einblendungsproblem, wenn die Subtitles aus der Source direkt kommt. Für mich ein klares KODI Problem, getestet habe ich es mit der aktuellen 18.7.2 . Müsste man mal schauen, ob die überhaupt von dem Bug wissen und eventuell in einer Nightly schon einen Fix haben.


    Ansonsten mal eine ältere KODI Version 17.6. oder ähnliches testen.


    https://xbmc.de.uptodown.com/android/versions


    Mehr kann ich da im Moment leider auch nicht helfen.

    Gruss Lony


    Mediaplayer: ZIDOO Z1000Pro, ZIDOO Z9x, ZIDOO X9s, UGOOS AM6 Plus, VERO 4K+

    TV :Sony KD-75XD9405, LG 49SM8500PLA

    SAT-Receiver: Vu+ Uno 4K SE mit VTi 14.0.5

    AVR Denon X3600H

    SOUNDSYSTEM :Teufel System 6 THX 5.2.2

    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED, DS216Play - 2 x 2TB WD RED

  • Hallo Lony,


    vielen Dank für das Feedback. Ich habe dieses Problem sowohl mit der Kodiversion, die in der CFW 2.1.4 enhalten ist (17.6?), als auch mit der aktuellen stable. Und das auf zwei unterschiedlichen Playern (beide Q10 Pro). Fehler scheint man hier melden zu können: https://github.com/xbmc/xbmc/i…ew?template=bug_report.md

    Ist aber ganz schön viel Aufwand, vorallem wenn man nicht so im Thema drin ist. Werde das ganze vllt mal am Wochende machen.

  • Am Himedia liegt es nicht, der Fehler ist auch auf einem RTD1295 und auch auf Allwinner H616 SoC. Könnte noch mehr SoCs testen, aber leider fehlt die Zeit.

    Gruss Lony


    Mediaplayer: ZIDOO Z1000Pro, ZIDOO Z9x, ZIDOO X9s, UGOOS AM6 Plus, VERO 4K+

    TV :Sony KD-75XD9405, LG 49SM8500PLA

    SAT-Receiver: Vu+ Uno 4K SE mit VTi 14.0.5

    AVR Denon X3600H

    SOUNDSYSTEM :Teufel System 6 THX 5.2.2

    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED, DS216Play - 2 x 2TB WD RED

  • Ich habe das mal bei mir auch mal getestet...

    Unter 18.7: Flackern, und ich meine auch das Bild hat unregelmäßige Micro-Ruckler.

    Unter 17.6(reine Vodoo-Fork): Kein Untertitel-Flackern, und zunmindest 'weniger' Micro-Ruckler.


    Scheint imho ein Kodi 18.x-Problem zu sein.. hmm

  • Also wenn ich mir die Datei ansehe ist es keine DVD Iso (Empfehlung BT 2020 definiert zwei Auflösungen, 3840 × 2160 die andere ist unwichtig da noch nicht darstellbar)

    Außerdem warum BT 709 (HDTV?)

    Außerdem wenn 4K Iso wieso dann nicht BT 2020?

    Wurde diese Datei konvertiert?

    Bitte ein Rip aus dem Original (Quellformat) ohne Konvertierung.

    Diesen Rip mit z.b. Mkvtoolnix erstellen und posten.

    Panasonic TX 58DXX789
    AVR: Yamaha RX V 631 Multicast
    Kodi 18.8 (Leia) mit Skin ACE 2.0

    HiMedia Q10 Pro + 9x8 TB WD + Int. 8 TB WD Script @messer, CFW 2.14 by @moere22

    Synology DS 1618+ mit 6x 8 TB WD RED
    Synology DS 1618+ mit 6x 10 TB Ironwolf

    Synology DS 1618+ mit 6x 12 TB Ironwolf
    SSD M2 Sata 256 GB+ Leergehäuse

  • Ist eine DVD-ISO, schwierig da ein Schnipsel hochzuladen ;) Oder hast du eine Idee?

    Ja.

    1. Isobuster Datei extrahieren....


    2. Datei m2ts in MKVtoolnix laden..Reiter



    Reiter Ausgabe folgendses oder ä. eingeben.


    und schon ist es fertig...sauber hier bei 4min. Kannst aber auch andere Zeit-Einteilung vornehmen.

    Panasonic TX 58DXX789
    AVR: Yamaha RX V 631 Multicast
    Kodi 18.8 (Leia) mit Skin ACE 2.0

    HiMedia Q10 Pro + 9x8 TB WD + Int. 8 TB WD Script @messer, CFW 2.14 by @moere22

    Synology DS 1618+ mit 6x 8 TB WD RED
    Synology DS 1618+ mit 6x 10 TB Ironwolf

    Synology DS 1618+ mit 6x 12 TB Ironwolf
    SSD M2 Sata 256 GB+ Leergehäuse

  • Wir reden hier von einer DVD-ISO und jetzt sind wir bei einer BD.ISO :!:


    Sind die Probleme nun bei einer DVD oder bei einer BD !?


    Die Unterschiede sollten schon auf der Hand liegen.

    Gruss Lony


    Mediaplayer: ZIDOO Z1000Pro, ZIDOO Z9x, ZIDOO X9s, UGOOS AM6 Plus, VERO 4K+

    TV :Sony KD-75XD9405, LG 49SM8500PLA

    SAT-Receiver: Vu+ Uno 4K SE mit VTi 14.0.5

    AVR Denon X3600H

    SOUNDSYSTEM :Teufel System 6 THX 5.2.2

    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED, DS216Play - 2 x 2TB WD RED

  • Es war nur beispielhaft.

    Das gleiche funktioniert in gleicher Weise auch mit DVD-Iso.

    Hatte nur gerade keine DVD-Iso zur Hand....

    Panasonic TX 58DXX789
    AVR: Yamaha RX V 631 Multicast
    Kodi 18.8 (Leia) mit Skin ACE 2.0

    HiMedia Q10 Pro + 9x8 TB WD + Int. 8 TB WD Script @messer, CFW 2.14 by @moere22

    Synology DS 1618+ mit 6x 8 TB WD RED
    Synology DS 1618+ mit 6x 10 TB Ironwolf

    Synology DS 1618+ mit 6x 12 TB Ironwolf
    SSD M2 Sata 256 GB+ Leergehäuse

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!