Filme aus mehreren Dateien werden nicht vom Scaper erkannt

  • Hallo zusammen,


    seit einiger Zeit versuche ich erfolglos einige Filme die in zwei oder mehr Teile getrennt sind zu scrapen. Alle anderen Filme die nur aus einer Filmdatei bestehen werden erfolgreich erkannt.


    Meine Umgebung:
    - HiMedia Q10 Pro
    - Android 7.0.0 API Level 24 (kernel: Linus 3.18.24_hi3798cv2x)
    - Version Kodi 18.5
    - Skin: Estuary
    - ADDON: metadata.common.themoviedb.org v3.1.10
    - ADDON: metadata.themoviedb.org v5.1.10


    Je ein Film liegt in einem Verzeichnis, wobei der Verzechnisname dem des Filmttitels entspricht. Die Filenamen lauten dann Film_CD1.avi, Film_CD2.avi usw.


    Nachdem was ich bisher recherchiert habe, muss in Kodi unter "Einstellungen > Medien > Videos" der Punkt "Geteilte Videostücke verknüpfen" aktiviert sein, damit das erkennen der Filme erfolgreich ist. Leider brachte mich diese Einstellung dem Ziel nicht näher.


    Im Debug File werden die fehlenden Filme mit folgender Meldung angezeigt


    WARNING: No information found for item 'stack://nfs://192.168.178.22/volume1/video/Filme/0006 - Lost Memories (2002)/Lost Memories (2002)/lma_divi_CD1.avi , nfs://192.168.178.22/volume1/video/Filme/0006 - Lost Memories (2002)/Lost Memories (2002)/lma_divi_CD2.avi', it won't be added to the library.


    Ich habe versuchsweise eine advancedsettings.xml mit einem <moviestacking> Inhalt angelegt - das hatte auch nicht funktioniert. Allerdings vermute ich, dass ich das File unter /storage/emulated/0/Android/data/org.xbmc.kodi/files/.kodi/userdata nicht in dem richtigen Verzeichnis abgelegt habe. Denn im Lofile wird nur versucht ein advancedsettings.xml aus den beiden folgenden Pfaden zu laden.


    "No settings file to load (special://xbmc/system/advancedsettings.xml)" und
    "No settings file to load (special://masterprofile/advancedsettings.xml)


    Mein Testweise angelegtes advancedsettings.xml


    <advancedsettings>
    <cache>
    <buffermode>1</buffermode>
    <memorysize>786432000</memorysize>
    <readfactor>1000</readfactor>
    </cache>
    <moviestacking>
    <! - <cd / dvd / part / pt / disk / disc> <0-N> ->
    <regexp> (. *?) ([_.-] * (?: cd | dvd | p (?: ar)? t | dis [ck]) [_.-] * [0-9] +) (. *?) (\. [^.] +) $ </ regexp>
    <! - <cd / dvd / part / pt / disk / disc> <ad> ->
    <regexp> (. *?) ([_.-] * (?: cd | dvd | p (?: ar)? t | dis [ck]) [_.-] * [ad]) (. *?) (\. [^.] +) $ </ regexp>
    <! - movienamea-xvid.avi, movienameb-xvid.avi - ->
    <regexp> (. *?) ([._-] * [ad]) (. *?) (\. [^.] +) $ </ regexp>
    </ moviestacking>


    </advancedsettings>



    Mache ich etwas grundsätzlich Falsch?
    Habe ich etwas vergessen?


    Edit: Sorry ich fürchte der Thread ist in der falschen Kategorie gelandet. - Liebe Admins, Vielen Dank fürs verschieben in die richtige Kategorie


    Ich bin euch für jeden Hinweis Dankbar
    Alex

  • Update:


    Ich habe versuchsweise die zweite Filmdatei entfernt und danach die Bibliothek aktualisiert. Wenn keine zweite Filmdatei im Verzeichnis ist, wird der Film erfolgreich erkannt.


    Scheinbar besteht mein Problem nur aus einem Konfigurationsfehler in Kodi.


    Ich habe Kodi auch mal auf meinem Windows 10 Rechner installiert und dort habe ich das gleiche Problem. Meine Erkenntnis daraus: Wenigstens mache ich meine Fehler überall gleich :-(


    Grüße
    Alex

  • Je ein Film liegt in einem Verzeichnis, wobei der Verzechnisname dem des Filmttitels entspricht. Die Filenamen lauten dann Film_CD1.avi, Film_CD2.avi usw.

    Versuch es mal, indem Du am Ende statt "CD1" etc. "part1" etc. schreibst,
    also:


    Filmname (Jahreszahl) part1.avi
    Filmname (Jahreszahl) part2.avi


    (So wie hier mit den Leerzeichen zwischen Filmname, Jahreszahl in Klammern und dann den Parts.

  • WARNING: No information found for item 'stack://nfs://192.168.178.22/volume1/video/Filme/0006 - Lost Memories (2002)/Lost Memories (2002)/lma_divi_CD1.avi , nfs://192.168.178.22/volume1/video/Filme/0006 - Lost Memories (2002)/Lost Memories (2002)/lma_divi_CD2.avi', it won't be added to the library.

    Ich guck grad noch mal auf die Warnung: Nach dem Pfad heisst die avi selbst ja anders als der Ordner,
    normal solls ja sein, z.B.
    Ordner "Heidi (2000)"
    und darin die Datei "Heidi (2000).avi"


    Die Warnung schreibt ja "no information found" - kann es sein, dass der Scraper nix mit einem Film namens "lma-divi" anfangen kann?

  • you made my Day !!!!!


    Ich kann aber nicht wirklich nachvollziehen, warum bei Filmen die nur aus einer Datei bestehen, der Dateiname keine Rolle spielt (Die werden nämlich bei mir immer gefunden) und bei Filmen die aus mehreren Dateien bestehen müssen die Filmdateien genauso wie das Verzeichnis lauten.


    Bevor ich nun anfange 100 Files umzubenennen suche ich mal noch nach einer weiteren Lösung


    Trotzdem vielen Dank für deinen wertvollen Hinweis


    Grüße
    Alex

  • Ich habe nochmal im Kodi-Wiki unter Absatz 2.1 nachgelesen und dort verstehe das so, dass wenn die Option "Filme liegen in getrennten Ordnern, die dem Filmtitel entsprechen" aktiviert ist, dann scrapt Kodi nach dem Verzeichnisnamen und wenn nicht, dann nach dem Filenamen.


    Vielleicht beschreibt aber dieser Satz aus dem Wiki mein Problem und es ist kein "kann" sondern ein "muss" "In light of the above, and because many users are unaware or forget this setting, Kodi recommends naming the movie file the same as the folder name as shown in the example image above"


    Grüße
    Alex

  • Hello Benny,


    vielen Dank für deinen Beitrag,aber mein Ziel ist es die Kodi-DB auf dem HiMedia Q10 zum laufen zu bringen. Die Windows Version von Kodi habe ich nur installiert, weil es hier für mich einfacher zum testen ist.


    ... oder gibts es tmm oder Ember auch als Androit Version?


    Grüße
    Alex

  • WARNING: No information found for item 'stack://nfs://192.168.178.22/volume1/video/Filme/0006 - Lost Memories (2002)/Lost Memories (2002)/lma_divi_CD1.avi , nfs://192.168.178.22/volume1/video/Filme/0006 - Lost Memories (2002)/Lost Memories (2002)/lma_divi_CD2.avi', it won't be added to the library.

    Das sagt das schon alles über den Fehler aus.
    Das ist die Crux bei der Online Suche. Du bist gezwungen den richtigen FN einzugeben. Weil der Scraper den Dateinamen ausliest.
    Wenn hier jetzt der FN (filmname) nicht richtig geschrieben wird, kannst du bis nächstes Jahr und darüber hinaus warten, er wird NIE was finden.


    Versuche es mal mit den Namen 2009 Lost Mem***** wobei die Sternchen zu ersetzen sind.


    Was @Berny, damit sagen wollte bei Ember oder TMM bekommst du die Möglichkeit einew temporäre Änderung des Filmnamen vorzu nehmen, was dir wiederum mehr Möglichkeiten der temporären Namensänderung gibt.


    Bevor du jetzt wieder sagst TMM gibt es nicht auf Android, ja das ist richtig, aber unwichtig da TMM .ifo Files anlegt, die du dann bequem mit Kodi wieder einlesen kannst..

    Panasonic TX 58DXX789
    AVR: Yamaha RX V 631 Multicast
    Kodi 18.9 (Leia) mit Skin ACE 2.0

    HiMedia Q10 Pro + 9x8 TB WD + Int. 8 TB WD Script @messer, CFW 2.14 by @moere22

    Synology DS 1618+ mit 6x 8 TB WD RED
    Synology DS 1618+ mit 6x 10 TB Ironwolf

    Synology DS 1618+ mit 6x 12 TB Ironwolf
    Synology DS 1618+ mit 6x 12 TB Ironwolf

    SSD M2 Sata 256 GB+ Leergehäuse

    tinyMediaManager Abo V 4.05

Jetzt mitmachen!

Sie haben noch kein Benutzerkonto auf unserer Seite? Registrieren Sie sich kostenlos und nehmen Sie an unserer Community teil!