Fehlende LAN MAC Adresse

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Fehlende LAN MAC Adresse

    Zidoo X9s wurde vor mehr als 20 Monate bei Gearbest gekauft. Ich hoffe, bei so einer ernstzunehmender Shop kein Klon erwischt zu haben, die angeblich billig bei Ebay im Umlauf sind, kosten etwa $80. Ich habe leider bis gestern nicht drauf geachtet, daß er keine valide LAN MAC Adresse hat. Auf die Verpackung, auf die Unterbodenplatte und auf die Mainboard ist die gleiche LAN MAC Adresse Aufkleber geklebt, taucht aber in der Einstellungen nicht und im DHCP Menu vom Router als 00:10:20:30:40:50
    Also ich hatte mal Crossflash mit der falschen Firmware von Zidoo Z9s, die habe ich mit Benutzung von USB TTL Kabel und die UART Schnittstelle auf die Hauptplatine mit Version 1.2.3 ersetzt. Da habe ich nachgeschaut, immer noch diese komische LAN MAC Adresse, Also auf Werkeinstellungen zurückgesetzt, keine Änderung. Dann die Full Image von Version 2.0.15 geflasht, immernoch nichts passiert, wieder auf Werkeinstellungen zurückgesetzt, keine Änderung.

    Ich kann mich nicht vorstellen, daß nach Firmware Flash die MAC Adresse gelöscht wird ?( ? Aber ist so. Wie kann ich die richtige LAN MAC Adresse wieder zurückeinstellen?
    Die WLAN MAC Adresse beginnt mit A0:2C.36:A0:XX:XX, also die gibt es.
    Der Aufkleber auf die Bodenplatte zeigt 80:0A:80:5A:XX:XX, laut heise.de ist dieser Hersteller:

    IEEE Registration Authority
    445 Hoes Lane
    Piscataway NJ 08554
    US

    Dieser LAN MAC Adresse ist ähnlich wie bei zidoo.

    Hier ein paar Screenshots:

    Erweiterte Einstellungen
    Bodenplatte
    Router

    Dieser Beitrag wurde bereits 6 mal editiert, zuletzt von slan ()

  • Bevor ich eine Antwort gebe, was passiert, wenn Du die Box hochfährst, welche Fehlermeldung erscheint im Zusammenhang mit der Mac Adresse.

    Screenshot reicht schon.

    Danke Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Hallo, du kannst über den Netzwerktreiber (Realtek oder ä). in den Einstellungen die originale MAC Kennug einstellen (wenn es der Treiber zuläßt). Denke mal das die Mac Adresse vorgetäuscht wurde.
    Unter Windows und Mac kann man das an fast jeder Netzwerkkarte, also man kann ein Spoofing vorgaukeln.
    Solltest dir mal Wireshark auf Windows installieren um ein (MAC Spoofing) bzw. ARP Spoofing auszuschliessen.

    Pansonic TX 58DXX789,HiMedia Q10 Pro + 9x8 TB WD + Int. 8 TB WD Script @messer, CFW 2.0.7 by @moere22
    AVR: Yamaha RX V 631 Multicast,
    Kodi 18.1 (Leia)
    Synology DS 1618+ mit 6x 8 TB WD RED
    Synology DS 1618+ mit 6x 10 TB WD Ironwolf
  • Generic mac 00: 10: 20: 30: 40: 50 can come from factory when Zidoo forgot to check if real mac address is was written on box or in some unlucky case of unbrick box via TTL console and mac address accidentally delete.
    A good news is Zidoo X9s running without problems on generic mac address.
    Other player from Dune, Eweat, Zappiti will not event boot with generic mac address.
    Are a tool witch can write mac address, but will need to get key files from Zidoo witch have your mac address.
    cnx-software.com/2017/03/16/ho…realtek-rtd1295-tv-boxes/
    Maybe our friends from 4pda know some more way to get key bin.

    Is also possible to temporarily change mac address via adb shell or add to /system/bin/install-recovery.sh file:
    ifconfig eth0 hw ether 'XX:XX:XX:YY:YY:YY'

    This options better to try and see if your real mac address are on Zidoo server and pass authentication process.
    Like many times post it here don't touch running box and don't try improve system witch fit your daily needs.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von pcristi ()

  • Lony schrieb:

    Bevor ich eine Antwort gebe, was passiert, wenn Du die Box hochfährst, welche Fehlermeldung erscheint im Zusammenhang mit der Mac Adresse.

    Screenshot reicht schon.

    Danke Lony
    Es kommt beim Hochfahren keine Fehler. Der Box startet sogar schneller mit dem Firmware 2.0.15, als mit der vorher benutzen Version 1.2.6 hoch.Ich habe eine 30 Sekunden Video gedreht, aber da bestätigt nur meine Aussage. Ich kann es auf Wunsch hochladen.

    Ich muß eine Kleinigkeit wegen die Meinung von pcristi machen: seit 2 Wochen habe ich meine VDSL Anschluß gekündigt, also seitdem hat Zidoo X9s kein Internetzugang mehr und vorgestern habe ich ihm geflascht(das übliche mit dem RESET Knopf, erst 1.2.3, Werkeinstellungen, dann 2.0.15, Werkeinstellungen), da er sich nach etwa 4 Stunden in Ruhestand selbständig neugestartet hat. Dies habe es deswegen bemerkt, da SPMC nicht gestartet war, als ich den Fernseher wieder eingeschaltet habe(Ausschalten mit dem Fernseher ist bei beiden Geräten aus bei HDMI CEC) und nach 4+ Stunden( Wenn ich den Fernseher ausschalte und nach etwa 5Minuten wieder einschalte, und SPMC ist gestartet, da zeigt mir das letzte, was ich vor dem Auschalten gesehen habe) Zidoo X9s im Hauptmenü war.

    Das wäre mir neu, wenn der Payer sein LAN MAC Adresse aus dem Internet bezieht. Es ist schon bekannt, daß er chinesische Server kontaktiert, diesbezüglich habe ich im August 2017 in einem schon offenen Thema im Zidoo Forum meine Meinung veröffentlicht.
    Dateien

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von slan ()

  • Wieso wenn deine Box hat eine generische MAC Adresse. Wie @pchristi postete.
    Diese generische MAC Adresse wird mit verschiedenen Servern in China validiert. (die auch deine gepostete Connection Zodoo.txt ausagt) Danach bekommt er die richtige Hersteller MAC Adresse.
    Nur steht in deiner Connection.txt am Ende "UNREPLIED" was soviel wie unbeantwortet heisst.
    Hänge ihn beim Flashen wieder ans Internet und alles ist gut.

    Pansonic TX 58DXX789,HiMedia Q10 Pro + 9x8 TB WD + Int. 8 TB WD Script @messer, CFW 2.0.7 by @moere22
    AVR: Yamaha RX V 631 Multicast,
    Kodi 18.1 (Leia)
    Synology DS 1618+ mit 6x 8 TB WD RED
    Synology DS 1618+ mit 6x 10 TB WD Ironwolf
  • Screenshot 2

    zusammen schrieb:

    ...Nur steht in deiner Connection.txt am Ende "UNREPLIED" was soviel wie unbeantwortet heisst.
    Hänge ihn beim Flashen wieder ans Internet und alles ist gut.
    Diese Connection Protokoll habe ich extra mit dem PC gemacht, es ist soweit her, ich weiß nicht mehr wie ich damals gemacht habe, entweder unter Linux oder Windows, ich wollte damals nur die Verbindungen von Zidoo X9s nach außen aufzeichnen.


    Also mit Putty und Telnet(da ich in OpenWRT von Zidoo X9s kein Passwort eingegeben habe, benutze ich OpenWRT von Zidoo zur Zeit nicht) habe ich das Befehl von pcristi eingegeben, kannte ich aber schon früher:

    ifconfig eth0 hw ether 'XX:XX:XX:YY:YY:YY'

    Also es hat sich was geändert, leider nur temporär, bis Zidoo X9s neugestartet wurde:

    Screenshot 1
    Screenshot 2
    Screenshot 3

    Danach ist die LAN MAC Adresse pfutsch. Aber er schreibt auch: "Is also possible to temporarily change mac address via adb shell or add to /system/bin/install-recovery.sh file:", wo ich aber admin Rechte brauche, vermute ich.Also muß ich rooten, zur Zeit nicht notwendig.
  • Also jetzt konkret was willst du?
    Wenn du eine Hersteller MAC Adresse haben willst musst du deine Box mit dem Internet verbinden. Danach wird sie validiert. Oder aber du machst es wie @pcristi postete aber nur temporär.

    @pcristii postete
    Mit dieser Option können Sie besser prüfen, ob Ihre echte MAC-Adresse
    sich auf dem Zidoo-Server befindet und den Authentifizierungsprozess
    durchläuft.
    Also wenn du in der system/bin keine Admin Rechte brauchst wann dann?

    @pcristi postet aber auch:
    Generic mac 00: 10: 20: 30: 40: 50 kann aus der Fabrik stammen, als Zidoo vergessen hat zu prüfen, ob die richtige MAC-Adresse auf der Box oder in einem unglücklichen Fall einer ungebrannten Box über die TTL-Konsole und die MAC-Adresse versehentlich gelöscht wurde.
    Eine gute Nachricht ist, dass Zidoo X9 ohne Probleme mit der generischen MAC-Adresse läuft.
    Andere Boxen von Dune, Eweat, Zappiti starten nicht mit einer generischen MAC-Adresse.

    Lony schrieb:

    Bevor ich eine Antwort gebe, was passiert, wenn Du die Box hochfährst, welche Fehlermeldung erscheint im Zusammenhang mit der Mac Adresse.

    Screenshot reicht schon.

    Danke Lony
    Außerdem bist du @Lony noch eine Antwort schuldig...

    Pansonic TX 58DXX789,HiMedia Q10 Pro + 9x8 TB WD + Int. 8 TB WD Script @messer, CFW 2.0.7 by @moere22
    AVR: Yamaha RX V 631 Multicast,
    Kodi 18.1 (Leia)
    Synology DS 1618+ mit 6x 8 TB WD RED
    Synology DS 1618+ mit 6x 10 TB WD Ironwolf
  • zusammen schrieb:

    ußerdem bist du @Lony noch eine Antwort schuldig...
    Da mach Dir mal keine Sorgen, wenn ich zu Hause bin, dann antworte ich noch, in der Zwischenzeit kannst Du Dir ja mal nen Zidoo besorgen, denn der Tickt ne Ecke anders, wie ein Himedia.

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Die ticken alle gleich, zumindest von Realtek Chip her.
    Übrigens mein HImedia hat eine echte Hersteller MAC. Soweit dazu.
    Es ist einfach unglaublich wie ein Kunde manchmal vorgeführt wird. (Zidoo)

    zusammen schrieb:


    Generic mac 00: 10: 20: 30: 40: 50 kann aus der Fabrik stammen, als Zidoo vergessen hat zu prüfen, ob die richtige MAC-Adresse auf der Box oder in einem unglücklichen Fall einer ungebrannten Box über die TTL-Konsole und die MAC-Adresse versehentlich gelöscht wurde.
    und letztendlich meinte ich in letzten Post das @slan DIR (und dem Forum ) noch eine Anwort zwecks Post #2 schuldig ist.

    Pansonic TX 58DXX789,HiMedia Q10 Pro + 9x8 TB WD + Int. 8 TB WD Script @messer, CFW 2.0.7 by @moere22
    AVR: Yamaha RX V 631 Multicast,
    Kodi 18.1 (Leia)
    Synology DS 1618+ mit 6x 8 TB WD RED
    Synology DS 1618+ mit 6x 10 TB WD Ironwolf
  • @slan

    If you box is rooted use Root Explorer to add line on /system/bin/install-recovery.sh ur via Windows adb shell

    Quellcode

    1. adb connect <ip_player>
    2. root
    3. adb connect <ip_player>
    4. remount
    5. adb shell echo "ifconfig eth0 hw ether 'XX:XX:XX:YY:YY:YY'" >> /system/bin/install-recovery.sh
    This trick will be remove by reinstall firmware or deleted command line from /system/bin/install-recovery.sh.
  • pcristi schrieb:

    @slan

    If you box is rooted use Root Explorer to add line on /system/bin/install-recovery.sh ur via Windows adb shell

    Quellcode

    1. adb connect <ip_player>
    2. root
    3. adb connect <ip_player>
    4. remount
    5. adb shell echo "ifconfig eth0 hw ether 'XX:XX:XX:YY:YY:YY'" >> /system/bin/install-recovery.sh
    This trick will be remove by reinstall firmware or deleted command line from /system/bin/install-recovery.sh.
    Ich beabsichtige keines Rooten von Zidoo X9s. Für mich ist ein Mediaplayer und SPMC läßt sich ohne Rootrechte installieren.

    Jedenfals danke ich Dir, im Falle, daß ich vorhabe, Zidoo X9s zu verkaufen und vorher will ich wissen, wie dies es den Box ändert.

    Ich muß zugeben, einmal auf Android System Admin Rechte mit Exploit erlangen zu haben, Kingroot, da hat alles komplett versaut(Sony Xperia Tablet Z 10 Zoll LTE), ich mußte mehrfach flashen, bis irgendwas tief in Betriebsystem wegzukriegen. Sehr viel Aufwand für nichts, mein Ziel mit Rooten von Sony Xperia Tablet Z war, da der interne Flashspeicher nur 16 GB ist, auf die externe SD Speicherkarte die Daten auszulagern. Seitdem kaufe ich nur was mit größeren Flashspeicher, mein Handy hat 64 GB, mein Tablet auch soviel. Nur Zidoo X9s ist mit nur 16 GB, aber da will ich nicht größeres installieren.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von slan ()

  • zusammen schrieb:

    Die ticken alle gleich, zumindest von Realtek Chip her.
    Übrigens mein HImedia hat eine echte Hersteller MAC. Soweit dazu.
    Es ist einfach unglaublich wie ein Kunde manchmal vorgeführt wird. (Zidoo)
    Ja aber nur von Realtekt Chip, nicht aber mit dem, was einem vorgesetzt wird. Ich habe Sie alle hier auf dem Tisch bzw. gehabt, ob nun ein Belink, EWEAT, MeLe, Zidoo, Zappiti und jeder tickt da anders. Was glaubst Du wohl, was passiert, wenn ich eine Zidoo Firmware auf einem EWEAT R9Plus installiere, Und die lässt sich einwandfrei installieren, nur was dann nach dem Boot kommt, wird Dir dann auf dem Monitor zelebriert und das heisst MAC Adresse, welche nicht zu dem Gerät passt, Woher die nun bezogen wird, die Antwort kannst Du Dir mal selber geben. Installiere ich hingegen eine Zappi auf dem Eweat, gibt es solch ein Syndrom nicht.

    Ich schätze Deine Kenntnisse wirklich, aber manchmal sitze ich hier und frage mich, wie Du denn nun einen Zidoo beurteilen kannst, oder gar einen Realtek 1295 oder 1296, wenn Du nicht einmal einen von denen auf dem Tisch stehen hast. Die Zeiten einen 1186 sind lange vorbei.

    Hier in diesem Fall, ist der Crossflash das Problem, denn der muss ja irgendwie Spuren auf dem System hinterlassen haben, denn nach einem erneuten Flash über die UART TTL Variante, hatte er die Büchse ja wieder am laufen, nur jetzt das Problem mit der Mac Adresse.

    @pcristi hat schon den richtigen Weg aufgezeichnet, dafür einmal Danke, denn da habe ich auch mal wieder was dazugelernt.

    Und nun zum Abschluss, ich mag vielleicht nicht solche fundierte Kenntnisse haben, nur ich lasse mich lieber vorführen, so ja Deine Worte, bekomme dafür aber ein Top Gerät, bevor ich mir die schwarze Schachtel wieder antue und mich an dessen so runden Lauf, wieder einmal 5 Tabletten in den Hals schmeissen muss, bevor ich draus nen Türstopper mache, mal unsachlich dargelegt.

    Und keine Bange ich gönne Dir Deinen Himedia, jeder das was er gerne haben möchte.

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • slan schrieb:

    Ich beabsichtige keines Rooten von Zidoo X9s. Für mich ist ein Mediaplayer und SPMC läßt sich ohne Rootrechte installieren.
    Wenn Du den Weg von @pcristi nicht gehen möchtest, dann setz Dich mit @mirror88 in Verbindung, schildere ihm Dein Problem, das Du versehentlich die Firmware einen Z9s installiert hast und jetzt das Problem mit der LAN Mac Adresse vorhanden ist. Ich denke der wird Dir sicherlich helfen, ein ähnlicher Fall war mal im Zidoo Forum und dem hat man auch wieder in die Spur gebracht.

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • zusammen schrieb:

    Also jetzt konkret was willst du?
    Wenn du eine Hersteller MAC Adresse haben willst musst du deine Box mit dem Internet verbinden. Danach wird sie validiert. Oder aber du machst es wie @pcristi postete aber nur temporär.
    Also ich habe mich die Mühe gegeben, über mein Handy( LTE FLAT 4GB) mit dem Zidoo X9s über Hotspot zu verbinden. Es hat nach Ausschtecken den Netzwerkkabel funktioniert, den habe ich vergessen vorher auszustecken.Ich kann nur über WLAN den Zidoo X9s mit Internet verbinden, für LAN Verbindung brauche ich Hardware dafür.

    Soweit sogut, es weigert sich zur neueren Firmware Version zu updaten, soweit ich weiß, gibt es letzendlich 2.1.19. Es zeigt mir: "Your Software is up to date".

    Hier die Screenshots:

    Verbindung mit dem Hotspot von meinem Handy
    Hotspot vorhanden(Internet Zugang über WLAN)
    Hotspot nicht vorhanden(ausgeschaltet; kein Internet Zugang über WLAN)

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von slan ()

  • er sagt Dir das die Box up to Date ist weil die 2.1.19 eine Beta Version ist und kein offizielles Release somit ist die Anzeige richtig . Wenn Du diese Fw installieren willst dann geht das nur über die gute alte USB Stick Methode
    4K HDR/DolbyVision LG Oled C8 * 4K HDR/DolbyVision Onkyo 5.2.2 DolbyAtmos/DTS:X THX AVR mit 7.2 THX Soundsystem * Real 4K UHDBD HDR i7-7700 HTPC * 4K HDR ZidooZ9s/X9s * Samsung Galaxy S9+ * AMD Octacore FX-8320 (8x 3,5 GHz) + 28" Samsung 4K Monitor * 4K HDR XBoxONE X
  • DaveO88 schrieb:

    er sagt Dir das die Box up to Date ist weil die 2.1.19 eine Beta Version ist und kein offizielles Release somit ist die Anzeige richtig . Wenn Du diese Fw installieren willst dann geht das nur über die gute alte USB Stick Methode
    Die will ich aber nicht, war für mich schon v.2.1.1 schwer wegzukriegen, downgrade auf v.1.4.12, die auch fehlerhaft war, da es viele bugs in HDMI CEC Steuerung gab, die wurden erst mit v.1.4.16 behoben. Ich wollte nur beweisen, daß eine Internet Verbindung bestand.

    Es ging um die LAN MAC Adresse, wenn Zidoo X9s mit Internet versorge, soll er LAN MAC Adresse auf Anweisung aus dem Internet kriegen.Tut er aber nicht.

    Lony hat eine Lösung für mich vorgeschlagen, die ich zwangsweise befolgen muß. Im Falle des Verkaufs der Zidoo X9s kriege ich Ärger mit dem Käufer(wenn er merkt), wenn die LAN keine gültige MAC Adresse hat. Sonst stört mir nicht, soweit keine weitere solche Geräte im Heimnetzwerk angemeldet sind.

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von slan ()

  • Thanks Lony for guiding me to this post :thumbup:

    I've tried adb method by Pcristi as my box is rooted by official Zidoo root app and the line was added successfully to the file , but unfortunately it did not succeed even after i flashed new FW , also I've ensured that the box is connected to internet while installing the new FW.

    Do you have any other ideas to restore my original MAC? I have no concern to test as my box is rooted, thanks all.
  • How to fix generic MAC address 00:11:22:33:44:55 or not set
    Connect to Realtek console
    help
    bdinfo
    -> check ethaddr is report <not set> or 00:11:22:33:44:55
    env edit ethaddr
    -> fulfill with correct MAC address
    env save

    This fix is usefully for Eweat/Zappiti players witch doesn't work with 00:11:22:33:44:55 MAC address.
    Keep on mind Zidoo player working well with generic MAC address don't touch working player.
    Use on your own risk.