Hyperion Grabber

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Hyperion Grabber

    Neu

    Hallo,

    ich befürchte ihr werdet mir auch nicht wirklich helfen können aber ich versuche mal mein Glück.

    Und zwar betreibe ich die Software Hyperion auf meinem Raspberry zu steuerung einer AMbilight nachbildung. Nun gibt es für Android einen Hyperion Grabber der das gezeigte Bild sozusagen an den Pi streamt. Das klappt auch soweit. Es werden alle Farben z.b. im Kodi richtig angezeigt aber sobald ich ein Video starte überträgt der grabber nicht mehr.

    Habt ihr eine Idee?
  • Neu

    Tester schrieb:

    ich befürchte ihr werdet mir auch nicht wirklich helfen können aber ich versuche mal mein Glück.
    Warum fragst Du erst, wenn Du der Meinung bist, hier kann dir keiner helfen. Schalt den Nativen ab,. dann haste auch dein Lichtspielchen in KODI.

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Neu

    Tester schrieb:

    Du meinst unter Einstellungen Stream player auf Nuplayer stellen?
    Zum einen, weiss ich nicht, was Du da genau vorhast, dann weiss ich nicht, ob Du nun KODI oder ZDMC nutzt und wenn ich davon spreche Du möchtest bitte den Nativen Player einmal deaktivieren, dann rede ich keineswegs vom NuPlayer, sondern eher vom Nativen Player, der unter KODI sprich ZDMC genutzt wird. Heisst für Dich, schwenk um auf die HW Unterstützung und teste es dann.

    Weiterhin kenne ich auch diese APP nicht und deren Verhalten, aber es gibt ja auch noch andere Möglichkeiten.

    Suche...............................

    Ambilight fuer meinen Samsung TV - was wuerde mich das kosten?

    Das Grundprinzip sollte das gleiche sein, oder aber Du lässt mal komplett die Katze aus dem Sack, was Du da denn nun mit dem Zidoo und den Rasperry vorhast.

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Neu

    Lony schrieb:

    Zum einen, weiss ich nicht, was Du da genau vorhast, dann weiss ich nicht, ob Du nun KODI oder ZDMC nutzt und wenn ich davon spreche Du möchtest bitte den Nativen Player einmal deaktivieren, dann rede ich keineswegs vom NuPlayer, sondern eher vom Nativen Player, der unter KODI sprich ZDMC genutzt wird. Heisst für Dich, schwenk um auf die HW Unterstützung und teste es dann.
    Ich kann nur den Nativen oder den Nu player auswählen sofern du diese Einstellung meinst.( Schnelleinstellungen ->Streamplayer)

    Grundsätzlich nutze ich ZDMC aber ich habe es sowohl über Kodi 18.6 als auch ZDMC probiert sobald ich ein Video abspiele gehen die Lichter nicht. Ich habe dann mal über den Kodi eigenen Player und NICHT über den Google Video Player abgespielt dann funktioniert das Lichtspiel

    Was ich nicht verstehe ist warum es kein Signal gibt wenn ich den Google Video Player nehme?

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Tester ()

  • Neu

    Tester schrieb:

    Ich habe dann mal über den Kodi eigenen Player und NICHT über den Google Video Player abgespielt dann funktioniert das Lichtspiel
    Bravo, dann solltest Du auch bitte richtig lesen, was ich geschrieben habe, denn das ist meine Aussage gewesen

    Lony schrieb:

    Warum fragst Du erst, wenn Du der Meinung bist, hier kann dir keiner helfen. Schalt den Nativen ab,. dann haste auch dein Lichtspielchen in KODI.
    Das hatte ich schon im 2.ten Posting geschrieben, den nativen abzuschalten.

    Tester schrieb:

    Was ich nicht verstehe ist warum es kein Signal gibt wenn ich den Google Video Player nehme?
    Das steht in der Wrapper Guide beschrieben und ich werde dieses jetzt nicht noch einmal erklären.

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Neu

    Tester schrieb:

    Ok, Danke für die Hilfe sonst wäre ich nicht auf die Idee gekommen das es am Player liegt. Ich suche mal ob ich die benötigte info finde.
    Der Player hat damit nichts zu tun, das Problem ist die fehlende HW Unterstützung für alles, sodass man nur auf diesen komischen KODI Videoplayer aufsetzen könnte. Nativ greift halt die Android Einstellungen ab und warum und wie sollte klar sein.

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Neu

    Das warum und wieso hab ich verstanden. Ich benutze diese APK
    hyperion-project.org/threads/android-screen-grabber.2708/

    Es greift einfach den Komplette Bild ab und reicht es an Hyperion weiter d.h. durch die Abtrennung des Google Players fehlt hier dann das Signal. Siehst du denn keine möglichkeit das durch den Wrapper zu schleifen bzw der App zu übergeben?
  • Neu

    Tester schrieb:

    Es greift einfach den Komplette Bild ab und reicht es an Hyperion weiter d.h. durch die Abtrennung des Google Players fehlt hier dann das Signal. Siehst du denn keine möglichkeit das durch den Wrapper zu schleifen bzw der App zu übergeben?
    Nur der App Entwickler kann an der Tatsache etwas ändern, indem er den Systemplayer mit unterstützt, demzufolge müsste er dann auch die Android Einstellungen mit in seine App aufnehmen. Nun bin ich auch kein Progger und so wie ich das sehe setzt er ja auch auf OpenGL auf, welches HW Spezifisch angelegt ist, denke ich mal. Sicherlich kann man Dinge mit dem Wrapper vervollständigen, aber keinesfalls alles abdecken, d.h. mit dem Wrapper kannst Du Deine Filme von Platte mit dem nativen abspielen und die Streamingdienste, wie YouTube etc. über den VideoPlayer von KODI, dann hättest Du zu mindestens, die halbe Miete bezahlt.

    Das ist nu einmal der Nachteil eines externen Players.

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED