Einstellung Zeitverzögerung beim Booten

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Immer noch die Frage, was willst du verzögert starten?
    Gruß
    moere

    Zidoo X9S | Open Hour Gecko | HiMedia H8 Octa | HiMedia Q5 4K3D Quad | HiMedia Q5 Pro | VidOn Box | EWEAT EW902 | HTPC intel i5, 4GB, 128GB SSD, Win7, iR
    Yamaha AV RX-V473 | Panasonic TX-P50VT20EA (Plasma 3D) | Playstation 3 | NAS Synology 414j 4x4TB (HMS5C4040BLE640)

    ehem. Player: HiMedia Q6-II eMMC | MiniX Neo X8-H | Phantom MX4 | Tronsmart Vega S89-H


    Custom Firmware



    Dir gefällt die CFW, dann würde ich mich über eine kleine Spende freuen.

    SPENDEN
  • moere22 schrieb:

    Immer noch die Frage, was willst du verzögert starten?
    Ich denke die gemounteten Shares sind nicht schnell genug verfügbar ?( g_biggrin
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • CH98123ch schrieb:

    Die gemounteten Shares sind nicht schnell genug verfügbar.
    Und mit welchem Script arbeitest Du denn da jetzt, mit dem von @messer oder etwas anderes.

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • CH98123ch schrieb:

    Genau, ich habe inzwischen 2 x 4 TB und 2 x 8 TB an der Box hängen. 3 Platten werden gefunden, die eine 8 TB aber nicht (nur manchmal).
    habe an anderer Stelle schon mal gepostet das ich 9 USB Festplatten an der Box hängen habe.
    Ja es dauert etwas bevor alle Platten angesprochen werden können.
    Starten die immer neu (z.b. Netz einschalten) oder sind im Standby. Wenn im Standby, dann hat die Platte schon eine Macke..und die wird nicht besser.
    Wenn sie im Standby waren hilft es manchmal schon sie aus und wieder ein zu schalten.
    Zu guter letzt Hilft es den SManager noch mal aufzurufen (händisch) um das Script nochmal zu starten, wird dann im Protokoll bei den anderen "skipped" angezeigt weil sie schon gemounted sind. Wird da dann die 1 Platte neu erkannt und gemounted?

    Die andere Möglichkeit wäre das Script nach dem Booten der Box später aus zuführen, dazu musst du im Scrpit selbst Die Zeit verändern bis zu 300 sec. (5 Min.) sind möglich. (Aber Vorsicht wo du das Script veränderst)
    Oder du mailst an Messer das er ein Script schreibt wo die Vorgabe (Massagebox mit Handeingabe) geregelt wird.
    Pansonic TX 58DXX789
    HiMedia Q10 Pro
    AVR: Yamaha RX V 631 Multicast
    Firmware 2.0.6 CFW
    by @moere22
    Android 7.1
    Kodi 17.6 (Krypton)
    UHD Samsung K8500
    Synology DS 1618+ mit 6x 8 TB WD RED
  • Tach, tach,

    irgendwie raufe ich mir gerade ein wenig die (nicht mehr vorhandenen) Haare ?( ...

    ... was soll ich eigentlich noch alles in die Beschreibung des Scriptes reinschreiben?

    Wenn Ihr Euch die beiden angehängten Screenshots einmal anschaut, dann werdet Ihr feststellen, dass das Script nicht geändert werden muss und dass die Eingabe des Wertes für die Wartezeit (in Sekunden) ebenfalls ganz einfach ist.

    Auch wenn das jetzt arogant klingen sollte (mit dem Risiko kann ich leben) empfehle ich, die Beschreibung nochmals genau zu lesen - da steht meines Erachtens alles haargenau drin. Sollte irgendjemand Verbesserungsvorschläge dazu haben, so werde ich die Dokumentation gerne in entsprechender Richtung überdenken und auch anpassen ... aber meines Erachtens steht da wirklich alles drin.

    Beste Grüße
    messer
    Bilder
    • Script-Dokumentation.png

      69,19 kB, 934×772, 7 mal angesehen
    • Screenshot_SManager.png

      155,35 kB, 1.080×2.160, 5 mal angesehen
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC: Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.6
    Mediaplayer aktuell : Zidoo X9S
    Mediaplayer früher : UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 13.0.1
    AVR: Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS: Synology DS-1817+ mit 3 * 12TW WD Gold + 4 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390
  • habe mir nochmal deine Beschreibung zu dem Script durch gelesen darin schreibst du u.a.
    "da Android beim Boot-Vorgang sehr busy ist, kann es in Verbindung mit AutoStart-Tools vorkommen, dass automatisch gestartete Scripte die Mountpoints nicht sofort finden (Überholung beim Booten) - also bitte genug Zeitverzug „einplanen“
    Der Aufruf des Skripts geschieht im Hintergrund (bei autom. Start ) darum hat man händisch keine Möglichkeit die Zeit zu verändern. Die Massagebox erscheint ja beim Autostart nicht.

    Deshalb meine ich eine Möglichkeit mit einer Eingabemaske zu schaffen.

    Deshalb vielleicht eine Bildschirmeinblendung zum Ändern des von dir richtig angezeigten Arguments.Diese nachdem man die Zeit darin eingetragen hat, wieder ausblenden Scriptbearbeitung starten.
    Pansonic TX 58DXX789
    HiMedia Q10 Pro
    AVR: Yamaha RX V 631 Multicast
    Firmware 2.0.6 CFW
    by @moere22
    Android 7.1
    Kodi 17.6 (Krypton)
    UHD Samsung K8500
    Synology DS 1618+ mit 6x 8 TB WD RED
  • zusammen schrieb:

    Der Aufruf des Skripts geschieht im Hintergrund (bei autom. Start ) darum hat man händisch keine Möglichkeit die Zeit zu verändern. Die Massagebox erscheint ja beim Autostart nicht.
    Du hast insofern recht, dass Du den Start von SManager und damit auch den Start des Scriptes nicht beeinflussen kannst ...

    ... das musst Du aber auch gar nicht, da über die Paramterangabe (1 bis 300 Sekunden) das Script selber darauf wartet, dass Android den Bootvorgang soweit abgeschlossen hat und dann alle Mountpoints vorhanden sind (wie lange das dauert hängt halt u. a. von der Zahl und der Geschwindigkeit der Festplatten ab und muss daher ausprobiert werden).

    Daher ist eine Eingabe, wann das Script gestartet wird, gar nicht notwendig - sag einfach dem Script mittels Parameter via SManager, wie lange es warten soll bis es damit anfängt, die Befehle auszuführen.

    Beste Grüße
    messer
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC: Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.6
    Mediaplayer aktuell : Zidoo X9S
    Mediaplayer früher : UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 13.0.1
    AVR: Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS: Synology DS-1817+ mit 3 * 12TW WD Gold + 4 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390