Tipps für Emby for Kodi

  • Tipps für Emby for Kodi

    Vorab. Das ganze Szenario hat mich gestern bei einem Freund viel Nerven gekostet,
    da er mit der "normalen" Pfad setzung in der Emby Bibliothek einfach nicht weiter gekommen ist.

    Der Himedia Wrapper verlangt halt ein bisschen Kreativität ab, aber das ist ja nicht wirklich was neues.


    Ausgangslage ist:
    Ein (oder mehrere) Himedia pro Geräte + (Synology) NAS mit installierten Emby.

    Himedia Wrapper muss (für diesen Weg) natürlich (jeweils) auf SMB + Zugangsdaten eingerichtet sein.

    Kodi sollte am besten frisch installiert oder durch "Cache" leeren vollkommen blank sein.

    1.
    Den "User" embysvr (den legt Emby automatisch an) auf der "NAS" mit lese + schreib Rechten ausstatten.

    2.
    In der Emby Bibliothek beim auswählen eurer (Film/Serien) Verzeichnisse das ganze dann "Wrapper" freundlich bestücken:

    Verzeichnis:

    /volume1/Festplatte1/Filme(FP1) (das ist nur ein Beispiel) ; ))

    (Idealerweise sollten wohl keine Leer oder Sonderzeichen vorhanden sein)


    (Optionaler) Gemeinsamer Netzwerkordner

    smb://xxx.xxx.x.xxx/Festplatte1/Filme(FP1)

    (dieser optionale ist der Knackpunkt des ganzen)


    Das ganze dann für jede Festplatte wiederholen und die Bibliothek komplett einrattern lassen.

    3.
    Emby for Kodi Addon in Kodi installieren:

    (Dateimanager /Neue Quelle / kodi.emby.media
    Dann unter Addons die Zip (1.05) installieren und in der Repository (Kodi Emby Beta Addons) komplettieren.

    4.
    Emby for Kodi den Anmeldevorgang -MANUELL- ausführen (IP der NAS eingeben) und den embysvr als User nehmen.
    Jetzt sollte auch sofort das Syncen der Bibliothek anfangen.

    Danach Kodi beenden und neu starten.

    5.
    In Emby for Kodi Addon unter Einstellungen auf Nativ und SMB stellen.

    Kodi beenden und neu starten.

    Ihr könnt dann (die hoffentliche Erfolgreiche Pfadsetzung) auch recht einfach innerhalb von Kodi kontrollieren.

    Wählt einen Film aus, geht dort auf Informationen + den Reiter "Aktualisieren" und schaut unten auf den Pfad. Wenn der mit smb://.............anfängt,
    ist alles gut.

    Sollte das nicht der Fall sein und/oder der Wrapper rumzicken, dann kann man im EMBY Addon die Datenbank reparieren, neu syncen oder komplett zurücksetzen.

    Anschließend Kodi beenden und neu starten.

    Falls das alles nichts nützt, tja, dann hilft nur noch Lony......... :P
  • Lanni schrieb:

    Anschließend Kodi beenden und neu starten.
    Schönes Ding, vielen Dank für den Walk :)

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, X6Pro, Nvidia Shield, Fantec 4KS5700, VidOn AV200, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 5 THX Select
    HTPC ZOTAC CI520 Win7 Pro 64bit
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED