Profi gesucht: Bricked Box retten (RTD1295) via UART+TFTP

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Alles klar!

    Wenn Du dann alles zusammen hast und es funktioniert, könntest Du ja eventuell mal ein kleines Tutorial dazu schreiben, mit Bereitstellung aller Files. ;)
    Gruß
    moere

    Zidoo X9S | Open Hour Gecko | HiMedia H8 Octa | HiMedia Q5 4K3D Quad | HiMedia Q5 Pro | VidOn Box | EWEAT EW902 | HTPC intel i5, 4GB, 128GB SSD, Win7, iR
    Yamaha AV RX-V473 | Panasonic TX-P50VT20EA (Plasma 3D) | Playstation 3 | NAS Synology 414j 4x4TB (HMS5C4040BLE640)

    ehem. Player: HiMedia Q6-II eMMC | MiniX Neo X8-H | Phantom MX4 | Tronsmart Vega S89-H


    Custom Firmware



    Dir gefällt die CFW, dann würde ich mich über eine kleine Spende freuen.

    SPENDEN
  • ramses3 schrieb:

    Da die Emailadresse in dem Thread den du gepostet hast für einen Key auch schon nicht mehr funktioniert, spekuliere ich auf jemand der eine China Box mit RTD1295 Chipsatz hat und mir die einfach gibt.
    So einfach ist es dann aber auch leider nicht, denn ich habe bevor ich zur Arbeit bin, mal das System durchgescheckt und konnte auf dem Zidoo zbs. keine HDCP.bin finden. Ich schaue aber heute Abend bei EWEAT nach.

    Irgendeinen Key nehmen, wird meines Wissens auch nicht so einfach gehen, sofern ich einen finden sollte, denn in der Bin ist die Lizensierung für HDCP verankert und die wahrscheinlich Hersteller bezogen, d.h. nutze ich eine andere, kann das System sich durchaus auch quer stellen, denn wie man sieht, ist bei Deiner Box das Platinen Layout auch wieder etwas anders.

    Ich schaue aber trotzdem noch nach, aller Wahrscheinlichkeit wirst Du aber den Support Deiner Box einmal anschreiben müssen, ob diese den HDCP.bin KEY dir zumailen können.

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.9
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Lony schrieb:

    ramses3 schrieb:

    Da die Emailadresse in dem Thread den du gepostet hast für einen Key auch schon nicht mehr funktioniert, spekuliere ich auf jemand der eine China Box mit RTD1295 Chipsatz hat und mir die einfach gibt.
    So einfach ist es dann aber auch leider nicht, denn ich habe bevor ich zur Arbeit bin, mal das System durchgescheckt und konnte auf dem Zidoo zbs. keine HDCP.bin finden. Ich schaue aber heute Abend bei EWEAT nach.
    Irgendeinen Key nehmen, wird meines Wissens auch nicht so einfach gehen, sofern ich einen finden sollte, denn in der Bin ist die Lizensierung für HDCP verankert und die wahrscheinlich Hersteller bezogen, d.h. nutze ich eine andere, kann das System sich durchaus auch quer stellen, denn wie man sieht, ist bei Deiner Box das Platinen Layout auch wieder etwas anders.

    Ich schaue aber trotzdem noch nach, aller Wahrscheinlichkeit wirst Du aber den Support Deiner Box einmal anschreiben müssen, ob diese den HDCP.bin KEY dir zumailen können.

    Lony
    Ach Lony, wenn das so einfach wäre. Die box hat keinen support, keine Homepage und überhaupt nix ..
    da bei den chinaboxen der chipsatz gleich ist und die gpu zu allem überfluss auch noch, rechne ich mir sehr gute chancen mit einer anderen hdcp.bin aus !

    Vielleicht hilft dir das als info:
    Du hattest mir ja das FLashtool aus "Beelink Realtek--Android TV BOX Upgrade Tools" zur Verfügung gestellt. In diesem Programm kann man eine Firmware angeben (unten links) und unten rechts müsste der HDCP key hin.
    Bin auch gerade auf der Arbeit und kann daher aus dem FF nicht sagen nach welchem Dateityp das Flashtool fragt.

    Ich hab jetzt auf jeden Fall schon alle möglichen Chinastore und Aliexpress Händler angeschrieben die das Ding verkaufen. Mal gucken ob/was da kommt. Ich zweifel.
  • ramses3 schrieb:

    Du hattest mir ja das FLashtool aus "Beelink Realtek--Android TV BOX Upgrade Tools" zur Verfügung gestellt. In diesem Programm kann man eine Firmware angeben (unten links) und unten rechts müsste der HDCP key hin.
    Das weiss ich, hier kann auch ein Schlüssel zur Verifizierung der Firmware hinterlegt werden, bei Beelink explizit reicht aber schon die Firmware selber, gleiches habe ich auch schon mit dem EWEAT EW902 gemacht, auch hier mit dem RTK Flashtool, denn das was Beelink da benutzt, ist direkt aus dem Hause Realtek.

    Ich habe jetzt auch mal eine Anfrage bei EWEAT reingereicht, habe aber wenig Hoffnung, das dieser mir einen zuspielt. Mal schauen.....

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.9
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • @Lony
    Also zumindest im Beelink forum hatte ich gelesen, dass die den hdcp schutz rausgenommen haben. daher ist die datei beim flashen vermutlich auch unsinnig, bzw die wird generell nicht aktuallisiert, weil die auf dem Gerät ist und immer gleich bleibt (schlüssel halt).

    Naja wenn das alles nix hilft, kann ich ja noch mal mit Firmwares auf dem Ding rumspielen. Immerhin weiss ich jetzt wie se tiefgehend retten kann :D

    Ich vermute mal, so wird es enden ...
    Noch ein weg wäre sich noch eine xnano zu kaufen, das image über den uart zu dumpen und dann auf die neue box zu flashen.
    Aber zwei mal "scheisse" ergibt dennoch nicht einen guten Player :D
  • ramses3 schrieb:

    Noch ein weg wäre sich noch eine xnano zu kaufen, das image über den uart zu dumpen und dann auf die neue box zu flashen.
    Aber zwei mal "scheisse" ergibt dennoch nicht einen guten Player
    g_shocked hrhr hrhr
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.9
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Wenn diese Datei auf keinem Player zu finden ist und zum Flashen von den Flashtools aber Angefordert wird, dann könnte man daraus schließen, das es sich "nur" um eine Schlüsseldatei handelt, deren Key vom Flashtool wie auch immer in das zu schreibende Image Eingeprägt wird. Vielleicht wird nur irgendwo, irgendeine Textdatei angelegt oder verändert, oder auch Programm-Teile einer bestimmten Datei mit dem Inhalt der HDCP.BIN gefüllt, oder das Flashtool schreibt den Inhalt direkt in einen bestimmten Flash-Speicher des Players. Da müsste man halt wissen wozu diese HDCP.BIN beim Flashen gebraucht/benutzt wird ... es wird ja seine Hintergründe haben, warum man so schwer an so eine Datei ran kommt. Drück' Euch die Daumen das es irgendwie klappt g_thumbs


    ramses3 schrieb:

    das image über den uart zu dumpen und dann auf die neue box zu flashen.
    Was aber auch nicht zwingend zum Erfolg führen muss, wenn der Schlüssel gar nicht im Image selbst enthalten ist, weil der vlt. in einen anderen Teil des Flash geschrieben wird.
  • Frischling schrieb:

    ramses3 schrieb:

    das image über den uart zu dumpen und dann auf die neue box zu flashen.
    Was aber auch nicht zwingend zum Erfolg führen muss, wenn der Schlüssel gar nicht im Image selbst enthalten ist, weil der vlt. in einen anderen Teil des Flash geschrieben wird.

    Jein. Wenn ein Flashprozess in der Lage ist diesen Bereich zu zerstören (durch falsches Image bzw falsche Partionierung) brauch ich mir um das runterdumpen keinen Kopf machen. Was schreibend geht, geht zu 99% lesend. Hier sowieso, der Key muss ja eingelesen werden.
    Das der Key irgendwo auf der Box sein muss, ist unumstritten.

    Wie und wo der jetzt landet ist ein anderes Thema. Mein weg sein das ich einfach bei 0x000000 anfange und aufhöre wenn keine daten mehr kommen. Da wird dann schon alles bei sein.

    Ich hoffe echt der gute Mann von Beelink meldet sich, der wird vermutlich um einiges mehr wissen. Ob er es auch sagt, wieder ein anderes Blatt ;(
  • ramses3 schrieb:

    So, noch einen schritt weiter. Ich habe mir jetzt einfach einen gültigen HDCP key generiert. Wie ich festgestellt habe sind die ziemlich Hardwareunabhängig.
    Respekt, den Generierer hatte ich auch schon gefunden, nur mit den Hash überstieg dann mein Kopf g_biggrin

    Schön zu sehen, mit welchem Einsatz Du da ran gehst g_thumbs

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.9
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Lony schrieb:

    ramses3 schrieb:

    So, noch einen schritt weiter. Ich habe mir jetzt einfach einen gültigen HDCP key generiert. Wie ich festgestellt habe sind die ziemlich Hardwareunabhängig.
    Respekt, den Generierer hatte ich auch schon gefunden, nur mit den Hash überstieg dann mein Kopf g_biggrin
    Schön zu sehen, mit welchem Einsatz Du da ran gehst g_thumbs

    Gruss Lony
    Ist ja auch eine super community hier :)
    Und wenn ich was beisteuern kann später, wieso nicht. Zumindest, wie du gemerkt hast, bin ich mir auch für "Experimente" nicht zu schade.
    Nur die neue X9S wird nicht crossgeflashed g_lol
    Gut das mir das mit dem Master key 2010 wieder eingefallen ist sonst wäre ich noch keinen Schritt weiter :D
  • ramses3 schrieb:

    Nur die neue X9S wird nicht crossgeflashed
    Nein das würde ich Dir auch verbieten wollen. :)

    Ansonsten für mich als Board Betreiber ein Lichtblick, das sich hier jemand hin verirrt, der sich in dieser Materie gut auskennt, denn diese Art Bricks kommen leider immer wieder vor und wirklich geholfen hat man uns von Seiten der Hersteller leider bisher nicht.

    Wäre eine tolle Sache, wenn Dein Workaround Früchte tragen würde :)

    Danke für den Einsatz hier auf dem Board.

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.9
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • @Lony

    Kein Problem. Habe doch auch was davon. Spätestens wenn die X9S kommt und es an das Thema Wrapper oder ähnliches geht, wirst du mir einen Vormachen :P

    Werde auf jeden Fall eine bebilderte Anleitung erstellen für solche Bricks, die ist dann zumindest universell für Realtek nutzbar.
    Wäre natürlich schön wenn sich vorher das HDCP löst, damit es direkt mit in die Anleitung passt, aber ich denke dieses Problem kommt weitaus seltener vor. Sonst hätte ich zumindest ansatzweise bei google was gefunden (bis auf die beelink sache).

    Denke mal spätestens am nächsten Wochenende wird sich da was ergeben.

    PS: eine Aliexpress-Händlerin will sich bei der Fabrik erkundigen wie das Problem behoben werden kann. Bin gespannt.
  • also muss man sich das nun so vorstellen :?: :?:
    Dateien
    LG Berny

    Ich bin zwar nicht dumm ,aber ich kann nicht alles wissen


    Herzlich
    Willkommen
  • Jein. Das ist wohl die "anwenderfreundliche" Lösung. Sowas kommt zb. zum Einsatz wenn der key geupdated werden muss.
    Die Xnano hat das Flashtool noch nie erkannt (vermutlich weil der Treiber im Gerätemanager mit einem geleben Ausrufezeichen markiert ist :) ) bzw. die Usb zu Usb-Lösung.

    Wäre froh wenn ich diese Variante nutzen könnte. Frag mich nicht warum das Tool bei mir nicht funktioniert. Ist bei dir das "Realtek generic USB Device" auch mit einem gelben Ausrufezeichen? Hab es auf einem Windows 10 und einem Windows 7 PC probiert. Beides das gleiche Ergebnis.

    Ich bin sicher es liegt am Treiber, denn der PC erkennt die angestöpselte Xnano auf jeden Fall als irgendein Gerät.
  • ramses3 schrieb:

    Ich bin sicher es liegt am Treiber, denn der PC erkennt die angestöpselte Xnano auf jeden Fall als irgendein Gerät.
    Nach der Variante hattest Du aber das Flash Tool installiert

    cnx-software.com/2017/03/16/ho…realtek-rtd1295-tv-boxes/

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.9
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • kann sein das er noch unsignierten Treibern unter Windows 10 freigeben muss ,ist nur ein verdacht da dies schon mit Win 7 los ging

    deskmodder.de/wiki/index.php/T…r_installieren_Windows_10

    ich muss da auch immer so vor gehen als ich früher das Handy mit ein speziellen Tool öffnen wollte
    LG Berny

    Ich bin zwar nicht dumm ,aber ich kann nicht alles wissen


    Herzlich
    Willkommen

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Berny ()

  • @Lony
    Ja, jetzt nicht direkt nach der ANleitung sondern nach diesen 5 Schritten die im anderen Thread geschrieben wurden, aber kommt aufs gleiche hinaus. Viel falsch machen kann man da mit nur einer setup.exe glücklicherweise nicht.

    @Berny
    Für Windows 10 würde die Anleitung wirklich sinn machen unter Windows 7 musste ich solche Spielereien nie durchführen.
    Das einzige, was mir zum ausprobieren noch einfällt, wäre ein wechsel von 64bit Windows auf 32bit Windows 7.
    Aber ob das die Lösung bringt bezweifle ich.

    Ich wäre euch dankbar, wenn ihr mal in den Gerätemanager unter Windows guckt und mir sagt, welchen Status der Treiber bei euch hat.



    PS: heute morgen hatte ich eine key_for_test - 副本.bin von beelink im postfach ..
    also heute noch mal mit flashtool fummeln und hoffen es läuft irgendwie
  • Ich mache heute eh 12.30 Schluss dann installiere ich das Tool noch einmal und such mir mal was zum Flashen, habe ja noch ein paar Bastelbuden g_lol

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.9
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED