Xnano X5 (RTD1295) zeigt nur eine Sekunde Bild nach boot

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Wenn ein EWEAT Logo angezeigt wird, hast Du denn mal die EWEAT Firmware im ganzen noch einmal per Stick versucht zu flashen, d.h. inkl. dessen Rescue Daten, ansonsten baue ich da eben auch noch einmal was hrhr

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Lony schrieb:

    Wenn ein EWEAT Logo angezeigt wird, hast Du denn mal die EWEAT Firmware im ganzen noch einmal per Stick versucht zu flashen, d.h. inkl. dessen Rescue Daten, ansonsten baue ich da eben auch noch einmal was hrhr

    Gruss Lony
    Aber natürlich habe ich das ! Hast du mir doch aufgetragen.
    In einem Thread sagtest du mal ich soll alles drauf kopieren aus dem eweat rar und dann ohne hdmi testen. Habe ich natürlich so ausgeführt :)
  • hmmm ich muss mal in mir gehen, wie ich mich an dem Boot vorbei schummeln kann.

    Eventuell muss ich mal meinen Joker bei EWEAT ansprechen, mal sehen ob der ne Brücke dafür hat.

    Ich bin noch dran....

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Lony schrieb:

    hmmm ich muss mal in mir gehen, wie ich mich an dem Boot vorbei schummeln kann.

    Eventuell muss ich mal meinen Joker bei EWEAT ansprechen, mal sehen ob der ne Brücke dafür hat.

    Ich bin noch dran....

    Lony
    Lony,. dir die Kiste einfach zu schicken war jetzt kein Spaßangebot :) Aber wenn du noch was sinniges rausbekommst, teste ich natürlich gerne weiter mit dir. Habe die Box quasi schon abgeschrieben.
    106€ für ne X9S, was sagste denn dazu? Da musste ich zugreifen :)
  • ramses3 schrieb:

    106€ für ne X9S, was sagste denn dazu? Da musste ich zugreifen
    Bekommst Du eine TOP Box habe davon selber zwei, kann RESO und Frameswitch und hat auch sonst ein schönes App Paket dabei. Firmware wird auch ständig verbessert, aber das kann man auch hier lesen. Vieles wird da aber auch unnötig mit rein gebracht, was keinen Mehrwert hat. Auf alle Fälle ist für den Kurs ein Schnapper. Nur Netflix und Konsorten, kann man abhaken, aber wer braucht das, wenn man schon alles im TV hat. Auf alle Fälle eine gute Entscheidung.

    So habe jetzt meinen Joker in Shenzen angeschrieben, mal sehen was Jonny sagt. Ansonsten schaue ich mich auch noch einmal um.

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Lony schrieb:

    ramses3 schrieb:

    106€ für ne X9S, was sagste denn dazu? Da musste ich zugreifen
    Bekommst Du eine TOP Box habe davon selber zwei, kann RESO und Frameswitch und hat auch sonst ein schönes App Paket dabei. Firmware wird auch ständig verbessert, aber das kann man auch hier lesen. Vieles wird da aber auch unnötig mit rein gebracht, was keinen Mehrwert hat. Auf alle Fälle ist für den Kurs ein Schnapper. Nur Netflix und Konsorten, kann man abhaken, aber wer braucht das, wenn man schon alles im TV hat. Auf alle Fälle eine gute Entscheidung.
    So habe jetzt meinen Joker in Shenzen angeschrieben, mal sehen was Jonny sagt. Ansonsten schaue ich mich auch noch einmal um.

    Lony
    Jep das dachte ich mir auch. Gut, ist jetzt nur nen UK Netzteil dabei, aber da passt ja sogar im schlimmsten Fall das Ding von der Xnana X5 :D Mit EU Netzteil wäre direkt der Preis bei 132 gewesen. Im schlimmsten adapter für 2 Euro bei Ebay. Is ja alles 240V.

    Ja das Firmware Argument ist mir durchaus wichtig (man war ich dämlich bei der Xnano nicht mal zu gucken ob es ne Homepage gibt, ich war defintiv vom Preis geblendet).
    Wäre natürlich echt super wenn wir die Box irgendwie wieder zum leben kriegen. Wie gesagt, Tochter freut sich.

    Du meldest dich wenn du was aus der Massen-Elektro-Metropole hörst? :)
  • Moin,

    Antwort aus Shenzhen ist schon da, aber er hat sauber an dem Thema vorbei geschrieben, keine Ahnung warum er blockt und meint ich wüsste nicht wie man einen Flash mit nem Stick macht hrhr hrhr bzw. mache ich das schon 5 Jahre und in Sachen Crossflash weiss ich schon, was möglich und nicht möglich ist.

    Dafür hat er mich auch wieder gleich mit allerlei Neuigkeiten zugetextet.

    Aber ich bin noch dran, muss wohl bei dem kleinen ein wenig energischer werden g_biggrin

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Lony schrieb:

    Moin,

    Antwort aus Shenzhen ist schon da, aber er hat sauber an dem Thema vorbei geschrieben, keine Ahnung warum er blockt und meint ich wüsste nicht wie man einen Flash mit nem Stick macht hrhr hrhr bzw. mache ich das schon 5 Jahre und in Sachen Crossflash weiss ich schon, was möglich und nicht möglich ist.

    Dafür hat er mich auch wieder gleich mit allerlei Neuigkeiten zugetextet.

    Aber ich bin noch dran, muss wohl bei dem kleinen ein wenig energischer werden g_biggrin

    Gruss Lony
    Kein Problem Lony. Ich bin ein geduldiger Mensch und was ändern ander Situation kann ich im Moment eh nicht.
    Ich warte brav auf Input von dir :D
  • ramses3 schrieb:

    Habe alles nötige dafür da, nur noch nie ein Android-Gerät über JTAG bearbeitet.
    Da bin ich auch schon dran gewesen, nur lässt sich mein Beelink nicht so ganz einfach bricken, da der nur mit dem Flash Tool bearbeitet werden will, trotz das er einen Reset Schalter unterwärts hat, der als Update gekennzeichnet ist.

    Nachher wenn der Besuch weg ist, schaue ich da auch noch einmal, auf alle Fälle können die Chinesen einen Brick wieder in Ordnung bringen, nur wie, das erzählen sie uns nicht. Beim Himedia geht es ja auch.

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • So ... ich konnte tatsächlich Seriellen Output abgreifen.

    Anbei das boot log.

    Er hängt nach der Zeile
    [ 5.621871] rtk-dwc3-type_c 98013200.rtk_dwc3_drd_type_c: Connection change OK: IN device mode to connect host at cc2 (cc_status=0x38)


    Sehe zwar einige Fehler in Bezug auf PCIE und USB HUB 2.0, aber das sollte keinen Start verhindern sondern lediglich nicht funktionierende USB Ports hinterlassen.
    Aber vielleicht sieht ja einer von euch etwas was ich nicht sehe.

    Der interessante Teil wird jetzt sein rauszufinden ob der JTAG nur eine Wartungsschnittstelle zum Auslesen ist oder ob man damit auch ein Image draufschieben kann.
    Dateien
    • ttl.jpg

      (91,54 kB, 7 mal heruntergeladen, zuletzt: )
    • putty20180311_110625.txt

      (16,62 kB, 4 mal heruntergeladen, zuletzt: )
  • JTAG ist ja eine Hardware Debugschnittstelle, wo man Fehler auslesen kann, so wie Du das gemacht hast.

    Muss ich mal recherchieren, ob über diese Schnittstelle auch mehr geht ?(

    Mal schauen was ich finde.

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • @Lony

    Die muss mehr können. Ansonsten würde es keinen sinn machen das es auch eine RX schnittstelle gibt. Für reines Debugging reicht Masse und TX.
    Von daher bin ich ich guter Dinge.
    Die Sonoff Smartswitche haben die gleiche Schnittstelle, da hat man über Arduino geflashed.
    Das einzige was es wirklich noch rausfinden gilt ist, WIE geflashed werden muss. Alles drumherum ist vorhanden :)
  • ramses3 schrieb:

    Das einzige was es wirklich noch rausfinden gilt ist, WIE geflashed werden muss. Alles drumherum ist vorhanden
    OK, dann müssten ja mit meinen bescheidenen Noob Wissen, die Rohdaten übermittelt werden, Ein Image macht ja dann so keinen Sinn, wenn ich das richtig sehe.

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Lony schrieb:

    ramses3 schrieb:

    Das einzige was es wirklich noch rausfinden gilt ist, WIE geflashed werden muss. Alles drumherum ist vorhanden
    OK, dann müssten ja mit meinen bescheidenen Noob Wissen, die Rohdaten übermittelt werden, Ein Image macht ja dann so keinen Sinn, wenn ich das richtig sehe.
    Lony
    Das ist die Frage. Solche Tricks wird dir alles dein shenzen-typ sagen können. Theoretisch müsste auch es auch möglich sein img/bin dateien darüber zu schieben. Aber google schweigt sich zum Thema Android/UART/Flashen ziemlich aus.
    Vieles gefunden aber nichts wirklich passendes.
    Es wäre durchaus denkbar, dass dafür ein richtiges Realtek-Tool benötigt wird.
  • So,

    jetzt habe ich eine console und kann auch Eingaben machen.
    goru - start rescue linux from usb habe ich schon versucht, funktioniert leider nicht.
    Ich habe einen TFTP server aufgesetzt und kann mit tftp $kernel_loadaddr uImage zb den Kernel ersetzen. Das funktioniert auch alles.

    Ist hier jemand mit dem Flashen via TFTP vertraut ? Die Frage ist jetzt, wie ich auf diesem wege das komplette Image neu drüberbügeln kann?!
  • da das Thema ,, Xnano X5 (RTD1295) zeigt nur eine Sekunde Bild nach boot´´ ist ist es ...............

    ramses3 schrieb:

    Ist hier jemand mit dem Flashen via TFTP vertraut ? Die Frage ist jetzt, wie ich auf diesem wege das komplette Image neu drüberbügeln kann?!
    ........... evtl. besser ein neues Thema zu öffnen um mehr User zu erreichen ;)
    LG Berny

    Ich bin zwar nicht dumm ,aber ich kann nicht alles wissen


    Herzlich
    Willkommen
  • Berny schrieb:

    da das Thema ,, Xnano X5 (RTD1295) zeigt nur eine Sekunde Bild nach boot´´ ist ist es ...............

    ramses3 schrieb:

    Ist hier jemand mit dem Flashen via TFTP vertraut ? Die Frage ist jetzt, wie ich auf diesem wege das komplette Image neu drüberbügeln kann?!
    ........... evtl. besser ein neues Thema zu öffnen um mehr User zu erreichen ;)
    Berny, ich glaube das ist eine gute Idee.