Kodi / ZDMC - CinemaVision

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Kodi / ZDMC - CinemaVision

    Hallo Zusammen!

    Nach weiterer Zeit hin- und herspielen mit dem ZidooX9S wollte ich mir das Kodi-Addon CinemaVision vorknöpfen.

    Als Ausgangsbasis nutze ich dafür die Kodi ZDMC Version.
    Darin kann man in den Einstellungen den externen Player ja nach belieben Aktivieren, oder deaktivieren.

    Mit dem externen Zidoo Player startet CinemaVision das erste Stück Medium und beendet daraufhin die Wiedergabe und spuckt mich zurück in meine Filmsammlung.
    Mit dem normalen Kodi Player funktioniert die App wie sie soll.

    Nun meine Frage, gibt es hier im Forum vlt. auch Mitglieder die mit CinemaVision arbeiten und auf selbiges Problem gestoßen sind?

    Würde mich über eine Antwort freuen!

    Lg, Andy
  • AndyK91 schrieb:

    Mit dem externen Zidoo Player startet CinemaVision das erste Stück Medium und beendet daraufhin die Wiedergabe und spuckt mich zurück in meine Filmsammlung.
    Mit dem normalen Kodi Player funktioniert die App wie sie soll.
    Da hier einige sicherlich nicht dieses Addon kennen, ich auch nicht, weiss ich so beim ersten lesen auch gar nicht, welches Problem da denn nun anliegt. Was bedeutet er spielt das erste stück Medium ?( und dann spuckt er dich zurück zu deiner Filmsammlung.

    Was soll dieses Addon denn machen und wie soll es sich verhalten, am besten mal eine Abfolge der Geschehnisse hier reinposten, damit wir uns mal einen Kopf machen können, was denn nun der native Player des Zidoos können muss.

    Danke Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Lony schrieb:

    AndyK91 schrieb:

    Mit dem externen Zidoo Player startet CinemaVision das erste Stück Medium und beendet daraufhin die Wiedergabe und spuckt mich zurück in meine Filmsammlung.
    Mit dem normalen Kodi Player funktioniert die App wie sie soll.
    Da hier einige sicherlich nicht dieses Addon kennen, ich auch nicht, weiss ich so beim ersten lesen auch gar nicht, welches Problem da denn nun anliegt. Was bedeutet er spielt das erste stück Medium ?( und dann spuckt er dich zurück zu deiner Filmsammlung.
    Was soll dieses Addon denn machen und wie soll es sich verhalten, am besten mal eine Abfolge der Geschehnisse hier reinposten, damit wir uns mal einen Kopf machen können, was denn nun der native Player des Zidoos können muss.

    Danke Lony
    Hi Lony,

    danke für den Hinweis, du hast Recht, Leute die das Addon nicht kennen, können mit meinem Problem eher nichts anfangen.

    CinemaVision ist ein Kodi Addon, dass ein Kino Vorprogramm aus verschiedenen einzelnen Medienschnipseln (meist Videos) zusammenstellt und VOR DEM HAUPTFILM nacheinander abspielt.

    Ein Vorprogramm kann beispielsweise so aussehen:
    HEIMKINO INTRO - WERBUNG 1 - WERBUNG 2 - TRAILER 1 - TRAILER 2 - KINOGONG - HAUPTFILM

    Mit dem Problem, "er spielt nur das erste Stück Medium ab" meinte ich, er spielt nur das HEIMKINO INTRO und wirft mich dann wieder zurück in meine Filmsammlung, allerdings ohne das komplette Vorprogramm oder den Hauptfilm zu zeigen.

    Wenn ich den externen Player in ZDMC deaktiviere, funktioniert es mit dem normalen Kodi Player.

    Hoffe nun ist mein Anliegen etwas verständlicher.

    Lg, Andy
  • AndyK91 schrieb:

    HEIMKINO INTRO - WERBUNG 1 - WERBUNG 2 - TRAILER 1 - TRAILER 2 - KINOGONG - HAUPTFILM
    Werbung 1 und 2, sowie Trailer 1 und 2 und KINOGong befinden sich wo ??

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Lony schrieb:

    AndyK91 schrieb:

    HEIMKINO INTRO - WERBUNG 1 - WERBUNG 2 - TRAILER 1 - TRAILER 2 - KINOGONG - HAUPTFILM
    Werbung 1 und 2, sowie Trailer 1 und 2 und KINOGong befinden sich wo ??
    Gruss Lony
    Das Addon legt auf einem ausgewählten Pfad eine Ordnerstruktur an, in dem man dann alles ablegt, was man verwenden will. Bei mir handelt es sich hierbei um eine externe Festplatte.
  • AndyK91 schrieb:

    in dem man dann alles ablegt, was man verwenden will. Bei mir handelt es sich hierbei um eine externe Festplatte.
    Und in diesem Ordner liegen was für Formate, Xvid, DivX, AVI............, bitte detailliert und der Haupotfilm liegt dort auch, oder dann wieder woanders.

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Lony schrieb:

    AndyK91 schrieb:

    in dem man dann alles ablegt, was man verwenden will. Bei mir handelt es sich hierbei um eine externe Festplatte.
    Und in diesem Ordner liegen was für Formate, Xvid, DivX, AVI............, bitte detailliert und der Haupotfilm liegt dort auch, oder dann wieder woanders.
    Lony
    Hauptsächlich .mkv, oder .mp4 Dateien.
    Auf der externen Festplatte habe ich im Grunde 2 Überordner:

    -FILME
    -CinemaVision

    In FILME befinden sich etliche Unterordner (also mit den Hauptfilmen). Ein Ordner pro Film, mit je einer .mkv Datei.
    In CinemaVision sind die Unterordner die vom Addon angelegt wurden.

    Wie gesagt, dass Addon macht alles richtig, wenn ich in ZDMC unter den Einstellungen den externen Player deaktiviere.
    Das ist auch die Sache, aus der ich nicht schlau werde.
  • Danke,

    ich installiere mir das mal auf mein System ohne ZDMC und schau es mir mal an, kann aber ein paar Tage dauern.

    Eventuell hast Du ja Zeit und kannst hier in der Zwischenzeit mal die JSON Datei posten.

    Der Quellcode würde schon reichen, einfach in einem Spoiler festmachen.

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Lony schrieb:

    Danke,

    ich installiere mir das mal auf mein System ohne ZDMC und schau es mir mal an, kann aber ein paar Tage dauern.

    Eventuell hast Du ja Zeit und kannst hier in der Zwischenzeit mal die JSON Datei posten.

    Der Quellcode würde schon reichen, einfach in einem Spoiler festmachen.

    Gruss Lony
    Das wäre ja super, vielen Dank! Aber nur keinen Stress :)
    Wenn du mir sagst wie ich an diese JSON Datei komme, poste ich den Quellcode gerne wenn es weiterhilft!

    Lg,
  • AndyK91 schrieb:

    Wenn du mir sagst wie ich an diese JSON Datei komme, poste ich den Quellcode gerne wenn es weiterhilft!
    Die sollte sich in einen der angelegten Ordner von CinemaVision befinden und regelt den Ablauf. Wenn Du sie nicht finden solltest ist es auch kein problem, sobald ich das Addon drauf habe, schaue ich da eh rein, muss mir nur noch Werbung und Trailer besorgen g_biggrin
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Lony schrieb:

    AndyK91 schrieb:

    Wenn du mir sagst wie ich an diese JSON Datei komme, poste ich den Quellcode gerne wenn es weiterhilft!
    Die sollte sich in einen der angelegten Ordner von CinemaVision befinden und regelt den Ablauf. Wenn Du sie nicht finden solltest ist es auch kein problem, sobald ich das Addon drauf habe, schaue ich da eh rein, muss mir nur noch Werbung und Trailer besorgen g_biggrin
    Solch eine Datei habe ich leider nicht gefunden. Bei CinemaVision speichert man sein Vorprogramm als .cvseq -Datei ab.
    Falls es etwas nützt, habe ich hier einmal mein Vorprogramm in den Spoiler gepackt:

    Spoiler anzeigen

    {
    "items": [
    {
    "enabled": true,
    "type": "action",
    "name": "SYNC",
    "settings": {
    "file": "/storage/54D8D96AD8D94ABE/Cinema Vision/Actions/Refresh Rate Sync Off.cvaction.txt"
    }
    },
    {
    "enabled": true,
    "type": "video",
    "name": "VORHANG",
    "settings": {
    "random": true,
    "count": 1,
    "vtype": "theater.intro",
    "play3D": true
    }
    },
    {
    "enabled": true,
    "type": "video",
    "name": "INTRO",
    "settings": {
    "random": false,
    "source": "/storage/54D8D96AD8D94ABE/Cinema Vision/Video Bumpers/Courtesy/Heimkino - Intro.mkv",
    "vtype": "courtesy",
    "count": 1,
    "play3D": true
    }
    },
    {
    "enabled": true,
    "type": "video",
    "name": "WERBUNG",
    "settings": {
    "random": true,
    "count": 3,
    "vtype": "trivia.intro",
    "volume": 100,
    "play3D": true
    }
    },
    {
    "enabled": true,
    "type": "trailer",
    "name": "TRAILER",
    "settings": {
    "count": 2,
    "source": "dir",
    "dir": "/storage/54D8D96AD8D94ABE/Cinema Vision/Trailers/",
    "filter3D": false
    }
    },
    {
    "enabled": true,
    "type": "video",
    "name": "LANGNESE",
    "settings": {
    "random": true,
    "count": 1,
    "vtype": "trivia.outro",
    "play3D": true
    }
    },
    {
    "enabled": true,
    "type": "video",
    "name": "KINOGONG",
    "settings": {
    "random": true,
    "count": 1,
    "vtype": "countdown",
    "play3D": true
    }
    },
    {
    "enabled": true,
    "type": "audioformat",
    "name": "",
    "settings": {
    "play3D": true,
    "method": "af.detect"
    }
    },
    {
    "enabled": true,
    "type": "action",
    "name": "",
    "settings": {
    "file": "/storage/54D8D96AD8D94ABE/Cinema Vision/Actions/Refresh Rate Sync On.cvaction.txt"
    }
    },
    {
    "enabled": true,
    "type": "feature",
    "name": "HAUPTFILM",
    "settings": {}
    }
    ],
    "version": 1
    }


    Oh ja, eine wahre Sucherei. Aber so banal wie es klingt, es macht Spaß vor dem Film ein kleines Vorprogramm zu haben, hat einen gewissen Charme den ich eigentlich nicht mehr missen will ;) Wobei es eigentlich totaler Quatsch ist.. Im Kino motzt man immer drüber und jetzt würd ichs mir daheim ansehen.. Man kann es einem auch nicht recht machen :rolleyes:
  • Danke das sieht schon interessant aus, nur eine kurze Frage, spielt er das Heimkino - Intro.mkv ab und stoppt dann alles weitere ???

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • AndyK91 schrieb:

    Sehr richtig, nach dem Heimkino - Intro spuckt er mich zurück in die Filmauswahl von Kodi.und die komplette Widergabe wird beendet.
    Danke, dann war meine Vermutung richtig, ok mal schaun, wenn ich alles druff hab und mir einen Test Ordner erstellt habe.

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Hatte heute Vormittag mal wieder etwas Zeit und habe mich mit dem Thema nochmal befasst.

    Mein letzter Stand war ja, dass ich den ZDMC benutzt habe und darauf hatte ich das Addon CV installiert.
    Habe den ZDMC deinstalliert und die neueste Version des ZDMC installiert.

    Parallel dazu, wollte ich nun mit der aktuellen Kodi Version inkl. Wrapper das Addon testen.
    Also unter Kodi 17.4 das Addon CinemaVision installiert. Dann muss man unter den Einstellungen, bei dem Reiter "Content" den Contentpfad auswählen (bei mir auf einer externen USB Festplatte), damit das Addon dann seine eigene Ordnerstruktur für die Medien anlegt. War für mich nichts neues, wollte ich machen, plötzlich motzte Kodi aber, dass der Ordner nicht erstellt werden kann und ich solle doch nochmal den Ordnernamen überprüfen. Das Problem liegt anscheinend an der externen Festplatte.. Wenn ich als Contenpfad die interne Festplatte des Zidoos auswähle, klappt das ganze..

    Daraufhin installierte ich mir das Addon wieder unter der ZDMC-Version, gleiches Ergebnis.. Jetzt weiß ich eben nicht was ich falsch gemacht habe, denn vor der neuesten Version klappte das Addon ja noch.. :huh: Klingt irgendwie so, als hätte ich nichtmal die Rechte dazu, eben einen Ordner anzulegen..

    Lony du hast nicht zufällig schon etwas Zeit gefunden, dir das Addon mal anzusehen?

    Lg, Andy

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von AndyK91 ()

  • AndyK91 schrieb:

    Lony du hast nicht zufällig schon etwas Zeit gefunden, dir das Addon mal anzusehen?
    Sorry hatte leider noch keine Zeit, musste ja leider hier ordentlich ran, habe Dich aber nicht vergessen, ich schaue es mir auf alle Fälle noch an, leider kommt immer wieder etwas dazwischen und Madam benötigt auch meine Aufmerksamkeit :rolleyes:

    Melde mich auf alle Fälle noch dazu.

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Lony schrieb:

    leider kommt immer wieder etwas dazwischen und Madam benötigt auch meine Aufmerksamkeit
    na hoffentlich... "oder unbewusst" g_lol
    Gruss Fred

    PS: Den Like-Button zu drücken, als Dankeschön, wäre nett...

    Spoiler anzeigen

    • Egreat A5 Zidoo X20 / X20 Pro
    • Samsung 65" 78" 88" curved
    • Dolby Atmos DTS:X Auro 3D
    • Denon AVX + Dynavox
    • Multiroom Channel > 7.2.8 + HEOS
    • Cambridge + Dali Audio LS Systeme
    • Velodyne Subwoofer DBA
    • QNAP NAS Systeme
  • Gibts hier mittlerweile ne Lösung? Bin durch stöbern drauf gestoßen und find das CinemaVision Addon recht interessant.

    Laut englischen Foren besteht hier das Problem, das CinemaVision nicht damit klar kommt, das ZDMC auf den externen Player zugreift. Hab aber nichts dazu gefunden ob man das mit dem Wrapper steuern könnte
    Samsung UE65MU7009
    Zidoo X9S
    Denon AVR x1400H mit 5.2.1 Selbstbau CerAl 4.2 Heimkinosystem
    Synology DS216j
  • DeadEye schrieb:

    Gibts hier mittlerweile ne Lösung? Bin durch stöbern drauf gestoßen und find das CinemaVision Addon recht interessant.

    Laut englischen Foren besteht hier das Problem, das CinemaVision nicht damit klar kommt, das ZDMC auf den externen Player zugreift. Hab aber nichts dazu gefunden ob man das mit dem Wrapper steuern könnte
    Leider nein. Ich würde CinemaVision öfter nutzen wenn der ZDMC Player es raffen würde, ALLE Videos von CV abzuspielen, doch er spielt nach wie vor nur eines ab und schmeißt einen dann wieder in die Filmsammlung.

    @Lony meinte er schaut es sich bei Gelegenheit mal an, schade dass er so ein vielbeschäftigter Mann ist :/

    Im Forum von CinemaVision gabs dazu auch nen Thread, die Admins dort haben drauf verwiesen, dass dies ein "Problem" seitens Zidoo ist. Den Link zum Thread hätte ich an Zidoo geschickt, aktuell von dort auch keine Rückantwort erhalten. Schade, meine Hoffnung wäre ja, dass sich das Problem irgendwann durch FW-updates etc. von alleine löst, fürchte aber dass das nicht passieren wird..
    Link zum CV-Thread: cinemavision.tv/forums/topic/1…s-player-problem-with-cv/
  • AndyK91 schrieb:

    @Lony meinte er schaut es sich bei Gelegenheit mal an, schade dass er so ein vielbeschäftigter Mann ist
    Sorry das ist leider so, denn neben diesem Forum, habe ich auch noch eine Selbstständigkeit und eine Familie, die auch meine Aufmerksamkeit benötigen. Ich versuche immer auf fast alles zu reagieren, ich hatte den Kollegen aber schon per PM geschrieben, das mir dieser Thread bei mir völlig in Vergessenheit geraten ist. Weiter ürde ich für meinen Teil, auch eine Lösung nicht mit ZDMC versuchen zu bewerkstelligen, sondern eher Wrapper KODI und ob es da dann funzt, kann ich nicht sagen, aber Plex habe ich damals auch hinbekommen, der im übrigen genau so, nur auf HW Unterstützung getrimmt ist und keine externen mag. Das die Progger von diesem Addon, es gerne wegschieben, ist normal, macht weniger Arbeit, warum also eine funktion für einen externen einbauen.

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED