Advanced Wake On Lan Addon unter KODI 17.3

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Advanced Wake On Lan Addon unter KODI 17.3

    Hallo Zusammen,

    vielleicht kann mir ja jemand auch mal helfen ;)

    Habe das obige Addon "Advanced Wake On Lan " unter KODI 17.3 installiert.

    Möchte gerne beim ersten Start von KODI, das mein NAS Synology aufwacht und zur Verfügung steht.

    Wake On Lan ist in der Synology aktiviert, das Addon habe ich auch mit allen erdenklichen (hoffe ich mal) Konfigurationen bestückt, IPS Adresse des NAS Server ist auch eingetragen. KODI gestartet, das Addon wird automatisch ausgeführt, aber die Syno will nicht erwachen aus dem Schlaf.

    Ist das Addon noch kompatibel zur KODI 17.3 ? Ich hatte es früher mal bei einer anderen KODI Version genutzt und da bin ich der Meinung, lief alles super.

    Für einen Tip wäre ich dankbar g_biggrin bevor ich wieder Tage damit verbringe, den Fehler zu finden.

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus/ W9, ZIDOO X9s, X6Pro, Nvidia Shield, Fantec 4KS5700, VidOn AV200, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 5 THX Select
    HTPC ZOTAC CI520 Win7 Pro 64bit
    NAS : (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Hi Lony,

    das Problem kenne ich ... funktionierte bei mir mit der DS-414 auch nicht. Werde es morgen mal mit der DS-1817+ testen und Bescheid geben.

    NACHTRAG:
    Ich habe den Test gerade mal "vorgezogen", weil ich es jetzt auch wissen wollte ;) . Um es vorweg zu nehmen, es funktioniert.
    Dabei ist mir allerdings folgendes aufgefallen: Beim ersten Versuch hatte ich die MAC-Adresse mit kleinen Buchstaben angegeben, da klappte es nicht, beim zweiten Versuch mit Großbuchstaben dann schon ...
    ... das Teil ist aber auch was von empfindlich :)

    Zudem ist mir aufgefallen, dass ich den letzten Test mit einer älteren DSM-Version seinerzeit durchgeführt habe - vielleicht liegt es ja auch daran.
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC : Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.3
    Mediaplayer aktuell : ./.
    Mediaplayer früher : Zidoo X9S / UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 11.0.2
    AVR : Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS : Synology DS-1817+ mit 5 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von messer ()

  • Danke @messer

    auf die MAC Adresse wäre ich nun nicht gekommen, vielen Dank für Deine Mühe, werde es nachher gleich mal testen g_thumbs

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus/ W9, ZIDOO X9s, X6Pro, Nvidia Shield, Fantec 4KS5700, VidOn AV200, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 5 THX Select
    HTPC ZOTAC CI520 Win7 Pro 64bit
    NAS : (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Hi,

    ich habe aus genau dem Grund mal über Wochen mit dem advanced WOL addon getestet.
    Letztlich ließ sich das Ganze besser mit Kodi Boardmitteln(Energiesparen, advancedsettings und wakeonlan.xml) und der integrierten WOL-Funktion umsetzen. Ich bin super zufrieden damit.

    Ich hatte damals (vor ca. 1,5 Jahren) auch den Eindruck, dass das advanced WOL addon nicht mehr gepflegt wird - ist das noch so ?

    Wie schon gesagt: ich wecke meine DS414 via WOL aus KODI auf (deep standby). Aber bevor ich über KODI-WOL jetzt lange schwafle... wenn daran Interesse besteht, gebt einfach laut, dann poste ich natürlich meine Konfig :D

    Hier gings ja um das addon. ^^

    SaEt9000
  • Also ich habe es jetzt gemacht wie @messer und meine 414 schläft immer noch g_igitt Irgendwas mach ich doch falsch, wenn es bei messer geht, muss es doch auch bei mir gehen.

    @SaEt9000

    Deine Config würde mich schon interessieren, wenn die läuft, dann kann ich mir doch das Addon schenken, auch wenn ich es nicht begreife, warum es nicht geht.

    Danke Lony
    Mediaplayer: EWEAT R9_Plus/ W9, ZIDOO X9s, X6Pro, Nvidia Shield, Fantec 4KS5700, VidOn AV200, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 5 THX Select
    HTPC ZOTAC CI520 Win7 Pro 64bit
    NAS : (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Lony schrieb:

    Also ich habe es jetzt gemacht wie @messer und meine 414 schläft immer noch Irgendwas mach ich doch falsch, wenn es bei messer geht, muss es doch auch bei mir gehen.
    @Lony ... ich habe mit der Disktation DS-1817+ getestet und nicht mit der DS-414 (die habe ich mittlerweile eingepackt für den Versand).

    Und wie oben geschrieben - bei der DS-414 bin ich vor einiger Zeit auch in Probleme gelaufen ... vielleicht ist das ja auch ein gerätespezifisches Problem?
    Im übrigen habe ich seinerzeit nicht nur das Addon versucht, sondern auch den Ansatz von @SaEt9000 und bin damit dann auch nicht weiter gekommen, so dass ich auf den Geräten schlußendlich entsprechende Apps installiert habe.

    @SaEt9000 - mich würde Deine Konfiguration auch interessieren.
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC : Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.3
    Mediaplayer aktuell : ./.
    Mediaplayer früher : Zidoo X9S / UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 11.0.2
    AVR : Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS : Synology DS-1817+ mit 5 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390
  • messer schrieb:

    ich habe mit der Disktation DS-1817+ getestet und nicht mit der DS-414
    Ok, das hatte ich gelesen, war daher der Hoffnung das es auf meiner DS414J funktioniert, ich vermute aber, das es bei dieser nicht geht, zu mindestens habe ich nichts gefunden in der Zwischenzeit, was ein WOL bestätigt.

    Mal sehen wie @SaEt9000 seine Conni aussieht, vielleicht klappt es damit ja.

    Trotzdem Danke.

    Lony
    Mediaplayer: EWEAT R9_Plus/ W9, ZIDOO X9s, X6Pro, Nvidia Shield, Fantec 4KS5700, VidOn AV200, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 5 THX Select
    HTPC ZOTAC CI520 Win7 Pro 64bit
    NAS : (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Der "Witz" ist, dass es mal funktioniert hat mit der DS-414 (ist aber schon einige Zeit her). Als es dann nicht mehr ging, hatte ich das Addon in Verdacht, aber das scheint ja zu funktionieren. Daher vermute ich, dass es was mit der DSM-Version und insbesondere mit den intergrierten Treibern zu tun - aber wissen tue ich es nicht.
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC : Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.3
    Mediaplayer aktuell : ./.
    Mediaplayer früher : Zidoo X9S / UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 11.0.2
    AVR : Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS : Synology DS-1817+ mit 5 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390
  • Meine DS ist ja nur im Sleepmode ( also nicht im WoL) und wacht bei Zugriff mit Kodi zuverlässig auf.
    zidoo X9S · amazon fireTV Stick · Panasonic TX-P46GW20 · Synology DS216j und DS215j · MacBook Air · FritzBox 7590
    Die richtige Formulierung eines Problems ist nicht selten bereits die halbe Lösung.
  • sprengbox schrieb:

    Meine DS ist ja nur im Sleepmode ( also nicht im WoL) und wacht bei Zugriff mit Kodi zuverlässig auf.
    Ja das macht meine auch hrhr aber ich strukturiere hier gerade ein wenig um, daher WOL g_biggrin
    Mediaplayer: EWEAT R9_Plus/ W9, ZIDOO X9s, X6Pro, Nvidia Shield, Fantec 4KS5700, VidOn AV200, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 5 THX Select
    HTPC ZOTAC CI520 Win7 Pro 64bit
    NAS : (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • so - mal schnell bevor ich jetzt alles runterfahre:

    Ganz wichtig ist natürlich in Kodi unter Energiesparen / "entfernte Server aufwecken" aktivieren und kodi dann neu starten. Ohne das geht nix :)

    Da meine WOL-Konfig die MySQL-DB anpingt, muss in der advancedsettings.xml auch die MySQL hinterlegt sein (in KODI 17 geht das jetzt wohl auch via GUI, aber sicher ist sicher)

    <videodatabase>
    <type>mysql</type>
    <host>192.168.x.yyy</host>
    <port>3306</port>
    <user>kodi</user>
    <pass>kodi</pass>
    </videodatabase>
    <musicdatabase>
    <type>mysql</type>
    <host>192.168.x.yyy</host>
    <port>3306</port>
    <user>kodi</user>
    <pass>kodi</pass>
    </musicdatabase>

    Zusätzlich muss die wakeonlan.xml ins userdata-Verzeichnis kopiert oder eventuell editiert werden.
    Meine sieht so aus:

    <onaccesswakeup>
    <netinittimeout>500</netinittimeout>
    <netsettletime>500</netsettletime>
    <wakeup>
    <host>192.168.x.yyy</host>
    <mac>00:EE:CC:DD:XX:YY</mac>
    <pingport>3306</pingport>
    <pingmode>0</pingmode>
    <timeout>1200</timeout>
    <waitonline>150</waitonline>
    <waitonline2>25</waitonline2>
    <waitservices>1</waitservices>
    </wakeup>
    </onaccesswakeup>


    Entscheidend sind die Parameter host und mac - klar. Genauso aber pingport und pingmode. Es sollte auch mit <pingport>445</pingport>
    <pingmode>0</pingmode>
    gehen. Dann muss man sich die anderen Parameter aber noch mal genauer ansehen.

    kodi.wiki/view/Wake_on_lan

    Der Vorteil bei pingport 3306 (SQL) ist, dass kodi so lange den Start unterbricht und wartet bis das NAS oben ist und die DB hochgefahren ist. Das dauert bei mir gut 2 Minuten für den Fall, dass das NAS im deep standby war.
    Andernfalls hast Du sonst eine leere lokale DB.
    Alles unter der Voraussetzung, dass die zentrale DB auf Deinem NAS liegt und nicht lokal.

    Viele Erfolg - bis morgen ;)
    SaEt9000
  • SaEt9000 schrieb:

    Ganz wichtig ist natürlich in Kodi unter Energiesparen / "entfernte Server aufwecken" aktivieren
    Jetzt weiß ich wenigstens, warum das bei mir damals nicht geklappt hat ... danke!
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC : Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.3
    Mediaplayer aktuell : ./.
    Mediaplayer früher : Zidoo X9S / UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 11.0.2
    AVR : Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS : Synology DS-1817+ mit 5 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390
  • Lony schrieb:

    ber ich strukturiere hier gerade ein wenig um, daher WOL
    Deine Stromjahresabrechnung bekommen? hrhr
    zidoo X9S · amazon fireTV Stick · Panasonic TX-P46GW20 · Synology DS216j und DS215j · MacBook Air · FritzBox 7590
    Die richtige Formulierung eines Problems ist nicht selten bereits die halbe Lösung.
  • Moin, moin,

    irgendwie bin ich zu blöd für den Ansatz mit der "wakeonlan.xml" ... ich habe jetzt die im Kodi-Wiki aufgeführten Varanten für "pingport" und "pingmode" ausprobiert, aber es tut's einfach nicht :( . Das Addon ist deinstalliert, so dass die beiden WoL-Varianten sich auch nicht wechselseitig beeinflussen können. Die Infrastruktur funktioniert, das habe ich mittels entsprechender Apps ausprobiert. Ich krieg so langsam eine mittelschwere Krise.
    Werde das Thema jetzt erst mal ruhen lassen ... nicht drüber nachzudenken hilft häufig bei der Fehlersuche.
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC : Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.3
    Mediaplayer aktuell : ./.
    Mediaplayer früher : Zidoo X9S / UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 11.0.2
    AVR : Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS : Synology DS-1817+ mit 5 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390
  • "WOL on LAN " in der DS hast Du sicher aktiviert (systemsteuerung - allgemein)?
    Evtl. ist das jetzt bei Deiner neuen High-End DS jetzt anders zu konfigurieren...

    Ich hatte bei meiner DS414 zwar die eine oder andere FW-Version, wo das automatische herunterfahren hakte, WOL ging aber immer.

    Was mir noch so einfällt:
    port 3306 ist ja SQL. Wenn ich es richtig verstanden habe, läuft die ganz neue "MariaDB" auf der DS auf 3307. Ich bin bei der herkömmlichen geblieben - ich vermisse auch bisher nichts.
    Port 415 ist samba/ SMB . Wenn ihr nur nfs nutzt, wird das vermutlich nicht gehen.
    Mit pingport 0 (default) hatte ich auch keinen Erfolg, wenn mich meine Erinnerung nicht trübt.

    SaEt9000
  • Hi @SaEt9000,

    danke für Deine Rückmeldung - ich merke mal wieder, der Frust hat mich unpräzise werden lassen.


    NFS ist bei mir nicht mit im Spiel, so dass ich den Part erst gar nicht betrachtet habe, sondern nur SMB .
    Da ich die Kodi-Datenbank nicht auf dem NAS-System ablege, bin ich das WoL-Thema mit den Ports 0 und 445 angegangen. Dabei habe ich für pingmode 0 und 1 ausprobiert. "WoL on LAN " hatte ich auch gecheckt - ist aktiviert ... sonst würden die dedizierten WoL-Apps und das Addon nicht funktionieren.

    Die Einstellungen werden bei den mir bekannten Diskstations dank DSM überall identisch vorgenommen (außer dass es bei den "größeren" Kisten ein paar Parameter mehr einzustellen gibt).

    SaEt9000 schrieb:

    Ich hatte bei meiner DS414 zwar die eine oder andere FW-Version, wo das automatische herunterfahren hakte, WOL ging aber immer.
    Falls noch nicht bekannt, versuche mal für das automatische Herunterfahren das Paket "Advanced Power Manager" ... damit hatte ich bislang keine (für mich ersichtlichen) Probleme.
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC : Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.3
    Mediaplayer aktuell : ./.
    Mediaplayer früher : Zidoo X9S / UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 11.0.2
    AVR : Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS : Synology DS-1817+ mit 5 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390