statisches Einbinden von USB-Festplatten

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Hallo @Zampano1234 ,

    danke für Dein schnelles Feedback!

    Grrr ;( - da werde ich dann wohl auch noch mal dran müssen. Allerdings werde ich den Aspekt mit geringer Priorität angehen, da das Skript ja prinzipiell funktioniert und ich derzeit anderweitig ziemlich ausgelastet bin.
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC: Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.6
    Mediaplayer aktuell : Zidoo X9S
    Mediaplayer früher : UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 14
    AVR: Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS: Synology DS-1817+ mit 4 * 12TW WD Gold + 4 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390
  • Basierend auf einem weiteren Tipp habe ich die Version 1.0.9 hier hochgeladen, mit der - hoffentlich - auch die letzte Warnung eliminiert werden wird.
    Da keinen Himedia mit Android 7 verfügbar habe, bin ich wieder auf Eure Test-Willigkeit angewiesen. Danke im Voraus!

    Auf meinem Android-6-Gerät funktiniert diese Version.

    NACHTRAG:

    Download wurde in die Filebase transferiert.
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC: Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.6
    Mediaplayer aktuell : Zidoo X9S
    Mediaplayer früher : UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 14
    AVR: Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS: Synology DS-1817+ mit 4 * 12TW WD Gold + 4 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von messer ()

  • Nochmals danke für's Testen!

    Dann lege ich das Thema jetzt mal ein wenig auf Eis ... meistens kommt dann doch eine Lösungsidee, wenn man gar nicht so intensiv drüber nachdenkt.
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC: Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.6
    Mediaplayer aktuell : Zidoo X9S
    Mediaplayer früher : UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 14
    AVR: Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS: Synology DS-1817+ mit 4 * 12TW WD Gold + 4 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390
  • So, damit es den hiesigen Testern nicht langweilig wird, habe ich einen Tipp von @pcristi aufgegriffen und die Anführungszeichen in dem Script nochmals angepasst.
    Dies hat zur Folge, dass jetzt auch Mountpoint mit Leerzeichen (z. B. "/mnt/media_rw/Filme & Serien") genutzt werden können. Allerdings dürfte dadurch die Warnung am Scriptanfang immer noch nicht behoben sein :( .

    Auf jeden Fall habe ich die neue Version 1.0.A nun hier für testwillige Experten mal angehängt - über Rückmeldungen würde ich mich freuen.

    NACHTRAG:
    Download-Datei wurde durch einen neuere Version in der Filebase ersetzt.
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC: Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.6
    Mediaplayer aktuell : Zidoo X9S
    Mediaplayer früher : UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 14
    AVR: Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS: Synology DS-1817+ mit 4 * 12TW WD Gold + 4 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von messer ()

  • @messer,
    ich habe dein überarbeitetes Script getestet. Schaue dir bitte die Bildschirmfotos vom Scriptfenster an, zeigen diese
    das erwartete Ergebnis ?

    Anmerkung: Mountpoint mit Leerzeichen habe ich allerdings noch nicht getestet.
    Bilder
    • Screenshot_20170803-081218.png

      152,59 kB, 1.920×1.080, 18 mal angesehen
    • Screenshot_20170803-081240.png

      147,2 kB, 1.920×1.080, 11 mal angesehen

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Zampano1234 ()

  • Hallo Messer & Co.
    da ich nun mit der CFW 2.0.4 bei meinem "Test-Pro" soweit bin und mal die interne und die externe Platte vom "Produktiv-Pro" anschließen kann, habe ich endlich mal bissi was zum Thema gelesen.

    Sehe ich das richtig, dass man sich gar nicht mit dem Thema/Script beschäftigen muss, wenn man eine interne und/oder externe Platte/n dauerhaft am Pro betreibt?

    Grüße
    Sven
    Heimkino:
    AVR = Marantz SR7010 plus MM7025 für 7.2.4, Projektor = JVC X7900
    heimkinoverein.de/fotos/album?albumid=1700
  • Zampano1234 schrieb:

    Schaue dir bitte die Bildschirmfotos vom Scriptfenster an, zeigen diese
    das erwartete Ergebnis ?
    @Zampano1234 ,

    wenn Du entsprechende Bilder einstellst, dann werde ich mir diese bestimmt ansehen ... momentan sind in Deinem Beitrag aber keine angehängt ...


    sven29da schrieb:

    Sehe ich das richtig, dass man sich gar nicht mit dem Thema/Script beschäftigen muss, wenn man eine interne und/oder externe Platte/n dauerhaft am Pro betreibt?
    @sven29da ,

    wenn Du dauerhaft bei einer Platte bleibst, dann mach das Script nur wenig Sinn (Pro: selbstsprechender Partitionsname).

    Wenn Du aber mehrere Plattenpartitionen gleichzeitig nutzt bzw. eine oder mehrere Platten an mehreren Playern nutzt, dann ist der Einsatz sinnvoll. Mehr dazu findest Du in der Filebase.
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC: Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.6
    Mediaplayer aktuell : Zidoo X9S
    Mediaplayer früher : UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 14
    AVR: Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS: Synology DS-1817+ mit 4 * 12TW WD Gold + 4 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390
  • Danke!

    Und nö, ganz so sollte es nicht aussehen ... aber die Bilder sind ein guter Hinweis für eine Version 1.0.B :D

    Mal schauen, ob ich das heute noch hinkriege.

    NACHTRAG:
    Yup, hier kommt die Version 1.0.B mit folgenden Anpassungen:

    • die Warnmeldungen 2 bis 5 (s. Screenshot in Beitrag 69) sollten wieder verschwunden sein
    • mehrfach auftauchende Zielpfade werden nur beim ersten Mal verarbeitet
    • leider ist die Warnung 1 immer noch nicht behoben
    Wie immer gilt: ich freue mich über entsprechende Rückmeldungen und ggf. über Screenshots


    NACHTRAG 2:
    Download-Datei wurde durch einen neuere Version in der Filebase ersetzt.
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC: Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.6
    Mediaplayer aktuell : Zidoo X9S
    Mediaplayer früher : UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 14
    AVR: Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS: Synology DS-1817+ mit 4 * 12TW WD Gold + 4 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390

    Dieser Beitrag wurde bereits 3 mal editiert, zuletzt von messer ()

  • Tach, tach,

    diese Android-7-Implementierung von Himedia bringt mich noch an den Rande des Wahnsinns ... auf dem Nougat-Gerät, mit dem ich gelegentlich testen kann, kommen die dargestellten Warnungen nicht :( ... wir machen hier also jetzt einen Blindflug auf Distanz ;( ...

    ... wenn ich das richtig sehe, dann gibt es anscheinend Unterschiede bei der Auswertung von Ausdrücken (im programmiertechnischen Sinne), die je nach OS-Implementierung unterschiedlich interpretiert werden. Daher habe ich in der neuen Version 1.0.C an einigen Stellen auf ein paar sehr kompakte und recht elegante Anweisungen verzichtet und stattdessen z. B. für die Überprüfung, ob ein Ziel-/Mount-Pfad doppelt vorkommt, entsprechende Schleifen eingebaut.

    Mal schauen, wie das Himedia-Android-7 damit zurecht kommt!?!

    Wie immer gilt: über Rückmeldungen - insbesonder mit Screenshots - würde ich mich freuen.

    NACHTRAG:
    Download-Datei wurde in die Filebase übertragen (05.08.2017)
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC: Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.6
    Mediaplayer aktuell : Zidoo X9S
    Mediaplayer früher : UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 14
    AVR: Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS: Synology DS-1817+ mit 4 * 12TW WD Gold + 4 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von messer ()

  • Hey, das sieht ja so aus wie es soll gr_haha ...

    ... bleibt also nur noch die Warnung direkt an dem Aufruf des Scriptes - da diese ja aber anscheinend keine Auswirkungen hat, werde ich das Script jetzt erst mal so lassen (es sei denn, es beinhaltet jetzt eine Verschlimmbesserung für eine andere Android-Variante) und in der Filebase ablegen.

    @Zampano1234 - nochmals herzlichen Dank für's Testen!
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC: Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.6
    Mediaplayer aktuell : Zidoo X9S
    Mediaplayer früher : UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 14
    AVR: Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS: Synology DS-1817+ mit 4 * 12TW WD Gold + 4 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390
  • Hallo,

    WARNING: linker: Warning: unable to normalize ""
    Is cause by how Script Manager call script not from script itself from logcat:

    Quellcode

    1. E/linker ( 6007): normalize_path - invalid input: "", the input path should be absolute
    2. W/linker ( 6007): Warning: unable to normalize ""

    Thanks @messer :D

    Dieser Beitrag wurde bereits 9 mal editiert, zuletzt von pcristi ()

  • pcristi schrieb:

    Is cause by how Script Manager call script not from script itself from logcat:
    English:
    If I don't misunderstand this statement it means that this is an issue of SManager and no issue with regard to the script.

    Deutsch:
    Wenn ich das nicht falsch verstehe, dann bedeutet das, dass es sich bei der Warnung nicht um einen Fehler des Scriptes handelt, sondern dass der Aufruf des Scripts über SManager der Grund für die Warnung ist ... also scriptseitig Entwarnung ;) .


    @pcristi : Thanks for what? You found the reason for the curious warning message - so it's up to me to say "THANKS a lot" for your support g_thumbs !
    Viele Grüsse
    messer

    PS: Den Like-Button zu drücken, tut nicht weh!
    -----------------------------------------------------------------------------------------------------------------------------------
    Spoiler anzeigen
    HTPC: Zotac CI540, 8GB RAM, 250GB SD, WIn10Pro x64, Kodi 17.6
    Mediaplayer aktuell : Zidoo X9S
    Mediaplayer früher : UncoreX / Xoro HST260S / Minix Neo X8-H / HiMedia Q10-II / DVico TViX M6500-A
    Fernseher : Samsung UE48H6600 + LG 32LA6608
    Sat-Receiver : VU+ Ultimo4K mit VTi-Team-Image 14
    AVR: Denon AVR-X 3300W
    Boxen : Energy Encore 5.1 - alt aber immer noch super! - Decken-LS folgen nach nächster Renovierung
    NAS: Synology DS-1817+ mit 4 * 12TW WD Gold + 4 * 4TB WD red
    Netzwerk : GB-LAN mit HP-Switch 1810-24Gv2 und AVM Fritzbox 7390

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von messer ()

  • Hallo @messer
    habe mich 2 Jahre lang gekonnt vor dem "basteln" gedrückt, da es mit der internen und der einen externen auch ohne Script immer klappte.

    Habe seit 3-4 Wochen eine weitere externe Platte dran und war öfters vorm ausrasten lol
    Das ganze, weil die zwei externen laufend ihren Namen "sda" und "sdb" tauschen.
    Somit habe ich im TMM alles doppelt und erst recht in KODI und das ganze geht mir auf den S... :cursing:

    Weil ich kein "Bastler" bin hatte ich unter anderem mich wieder von der 2.0.4 getrennt (mus sman hier nachlesen was mir noch missfiel) aber nun komme ich wohl so oder so um das Script nicht drum herum.

    Ist Dir bekannt ob moere in der letzten CFW was von Deiner Lösung ( android-mediaplayer.de/wsif/in…Versionen-4-bis-7-evtl-a/ ) implementiert hat?
    Dann würde ich nämlich auf die neue CFW warten, ansonsten kann ich (auch wenn keine Lust und Zeit :S ) Deien Lösung mit der alten FW versuchen es hinzubekommen.

    Ich brauche auch keine Partitionen, einfach nur das immer die Festplatte an USB Port x unter dem gleichen Pfad zu finden ist und ebenso die andere.
    Meine Platten bleiben nämlich dauerhaft am Pro angeschlossen.



    Danke und Grüße
    Sven
    Heimkino:
    AVR = Marantz SR7010 plus MM7025 für 7.2.4, Projektor = JVC X7900
    heimkinoverein.de/fotos/album?albumid=1700

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von sven29da ()