advancedsettings.xml

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • advancedsettings.xml

    wie oben schon im Titel erwähnt bräucht ich mal jemandens Hilfe um mir eine "advancedsettings.xml" zu erstellen
    da ich mich beim erstellen einer XML Datei generell irgendwie Blöd anstelle und diese dann auch nicht funktionieren könnte ich was das betrifft Hilfe in Anspruch nehmen, beim Zidoo werden alle Filme absolute Sahne wiedergegeben aber leider ist der Chach zu schnell voll und das dauerne Buffering nervt dann schon auf dauer gerade beim Streamen von 4K Filmen
    also wer könnte mir eine solche XML Datei schreiben ? Wer sich derer annimmt könnte auch bei funktionierender Datei dafür einen Obolus via PayPal erhalten - würde mich da nicht lumpen lassen
    sagt mir nur was ihr dafür an Daten brauch oder was auch immer ! ich werde es soweit zur Verfügung stellen .
    Ich denke auch das von dieser XML Datei auch andere Profitieren könnten da das Gerät für das ich diese verwenden möchte die Zidoo X6pro ist

    danke erst einmal im vorraus g_thumbs

    Edit : hab zwar soetwas gefunden aber ich blick da nicht durch kodi.wiki/view/Advancedsettings.xml
    also ich brächte ne fertige Datei die ich einfach nur in den "User Data Ordner" hinein kopieren brauch
    4K HDR/DolbyVision LG Oled C8 * 4K HDR/DolbyVision Onkyo 5.1.2 DolbyAtmos/DTS:X THX AVR mit 7.1 THX Soundsystem * 4K UHDBD HDR i7 HTPC * 4K HDR ZidooX9s * Samsung Galaxy S9+ * AMD Octacore FX-8320 (8x 3,5 GHz) + 28" Samsung 4K Monitor * 4K HDR XBoxONE X

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von DaveO88 ()

  • Hallo @DaveO88

    also ich denke es geht hier nicht ums bezahlen, wer hier dafür Geld nimmt, wäre ja arm dran, im übrigen sollte man doch in der Lage sein, so etwas innerhalb der Community in den Griff zu bekommen, d.h. man tauscht sich aus.

    Was möchtest Du denn genau erreichen, das das Buffering erhöht, also der Cache hierfür grösser wird, oder soll das buffering abgestellt werden.

    Ich bin da zwar auch kein Profi, aber XML erstellen ist kein Problem, muss dann nur mal die funktionierende Syntax zusammentragen und frickeln g_lol

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • zum einen hast ja Recht mit der Kohle, aber ich bin auch der Meinung wenn jemand seine Freizeit damit verbringt etwas zu erarbeiten wovon er evtl. nicht mal selbst was hat das das schon mal ein Trinkgeld wert ist, würde ich woanders auch machen
    aber OK sei es wie es wolle umsonst müsste es keiner machen g_thumbs

    ja klar das der Chash erhöht wird , und wenns komplett wegfallen täte wäre es mir auch recht
    film starten und das läuft bis zum ende - so soll's sein
    4K HDR/DolbyVision LG Oled C8 * 4K HDR/DolbyVision Onkyo 5.1.2 DolbyAtmos/DTS:X THX AVR mit 7.1 THX Soundsystem * 4K UHDBD HDR i7 HTPC * 4K HDR ZidooX9s * Samsung Galaxy S9+ * AMD Octacore FX-8320 (8x 3,5 GHz) + 28" Samsung 4K Monitor * 4K HDR XBoxONE X
  • Ich schau es mir die Tage mal an, was man da machen kann, bzw. wie die aussehen muss.

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Falls jemand mit basteln will g_biggrin

    kodi.wiki/view/HOW-TO:Modify_the_cache
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Ok hier mal die erste Learning by Testing

    Da sollte das Buffering ausgeschaltet sein *willhoff*

    Hatte noch keine Zeit das zu testen, ist auch heute schon zu spät, da sonst die Holde mir einen überzieht ;)

    Gruss Lony
    Dateien
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Wenn es das Buffering ausgeschaltet sein sollte, es aber dann trotzdem bedingt durch das nicht cachen Probleme gibt, bitte Bescheid sagen, dann muss das Buffering rein und es muss die Cache Grösse erhöht werden.

    Ich mach jetzt flach, bis morgen meine Sorgen g_biggrin

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Danke erst einmal
    Nein ist noch nicht weg , aber es Buffert schon viel weniger20151227_001359.jpg
    4K HDR/DolbyVision LG Oled C8 * 4K HDR/DolbyVision Onkyo 5.1.2 DolbyAtmos/DTS:X THX AVR mit 7.1 THX Soundsystem * 4K UHDBD HDR i7 HTPC * 4K HDR ZidooX9s * Samsung Galaxy S9+ * AMD Octacore FX-8320 (8x 3,5 GHz) + 28" Samsung 4K Monitor * 4K HDR XBoxONE X

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von DaveO88 ()

  • Ok dann schau ich morgen weiter, was man noch machen kann.

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • g_thumbs :*

    Das Problem dabei ist das durch das häufige zwischen Speichern irgendwann der Film abkackt und der Ton komplett ausfällt weil er irgendwie total durcheinander kommt
    4K HDR/DolbyVision LG Oled C8 * 4K HDR/DolbyVision Onkyo 5.1.2 DolbyAtmos/DTS:X THX AVR mit 7.1 THX Soundsystem * 4K UHDBD HDR i7 HTPC * 4K HDR ZidooX9s * Samsung Galaxy S9+ * AMD Octacore FX-8320 (8x 3,5 GHz) + 28" Samsung 4K Monitor * 4K HDR XBoxONE X

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von DaveO88 ()

  • DaveO88 schrieb:

    mal ein Trinkgeld wert ist,
    Das ist sehr löblich und kann ja auch als Board-Spende zur Anwendung kommen?

    Bei dem hier zu Grunde liegenden Problem stelle ich mir jedoch die Frage ob Änderung des Buffer-Cache überhaupt hilfreich sind. Die Zwischenpufferung findet ja eben statt, weil die Netzwerkverbindung offensichtlich zu langsam ist! Ohne Buffer wird der Film also ohne Ende ruckeln und mit größerem Buffer werden lediglich die Abstände zwischen den Puffer-Pausen etwas größer ... man kann den Cache ja auch nicht unendlich groß machen. Und man stelle sich vor wie lange das Buffering dauern würde, wenn der gesamte Film da rein gepuffert würde ...
  • Moin Zusammen,

    @DaveO88

    da Du in einem 1 GB Netzwerk die Filme Streamst, sollte es im Grunde genommen zu keinem Buffering kommen, Sollte !?

    Hast Du dieses Verhalten bei SMB und NFS oder expliziert nur bei einem der beiden Protokollen.

    Ich hänge hier noch einmal eine advancedsettings.xml an, teste diese einmal, ist alles experimental, da jetzt der RAM genutzt wird.

    Melde Dich einmal, hast Du diese Probleme auch mit anderen Mediaplayers, wie zum Beispiel Himedia.

    Gruss Lony
    Dateien
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Danke Lony, die hats gebracht g_thumbs

    nein Probleme mit anderen Playern hab ich nicht nur mit jene wo Kodi selbst genutzt wird also X6 und auch die Shield .
    aber wie auch schon erwähn sind BD Daten davon so gut wie nicht betroffen sondern nur Dateien jenseits der 50Gig Marke
    als ich nach dem Problem im Netz gesucht hab bin ich auch auf andere Foren gestoßen wo genau das gleich Problem aufgetreten ist also scheint das wohl ein Kodi spezifisches Problem zu sein
    und wenn ich kein Gbit NW hätte dann wäre das wohl wieder ein Grund gewesen das NW aufzurüsten da es aber nicht mehr besser werden konnte musste das Prob wo anders liegen aber dank Deiner Hilfe scheint es beigelegt zu sein zumindest was ich bis jetzt mir anschauen konnte

    also vielen vielen Dank dafür
    4K HDR/DolbyVision LG Oled C8 * 4K HDR/DolbyVision Onkyo 5.1.2 DolbyAtmos/DTS:X THX AVR mit 7.1 THX Soundsystem * 4K UHDBD HDR i7 HTPC * 4K HDR ZidooX9s * Samsung Galaxy S9+ * AMD Octacore FX-8320 (8x 3,5 GHz) + 28" Samsung 4K Monitor * 4K HDR XBoxONE X
  • Ja ich bin da leider auch überfragt, da ich das nicht nachstellen kann,

    Aber wenn es bei 4K zu solchen Buffering kommt, was für eine Leitung benötige ich denn dann.

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • DaveO88 schrieb:

    Danke Lony, die hats gebracht
    Danke für die Rückmeldung, manno seit gestern habe ich einen guten Lauf hier im Board hehehe

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • hi,

    ein evtl. hlfeicher Parameter - vor allem für gigabit-Netzwerke - kann der hier sein:

    <readbufferfactor>1</readbufferfactor>

    Der wird direkt im network-Abschnitt gesetzt:

    <network>
    <buffermode>1</buffermode>
    <cachemembuffersize>314572800</cachemembuffersize>
    <readbufferfactor>1</readbufferfactor>
    </network>

    Standard ist der Wert 1.
    Hier liegt meiner Meinung nach auch der Grund, warum viele kodi-Systeme schon bei bluray o.ä. in dieses Buffer-Problem kommen. Die vorhandene Bandbreite wird per default nämlich nicht genutzt.

    D.h. Dein gigabit "idle-t" vor sich hin - und bei bluray oder eben 4K kann es schnell mal so sein, dass der Datenstream dann abbricht.
    Buffern hilft da schon mal sehr (cachemembuffersize). - wenn Du die Werte aber zu hoch legst, nimmst Du Dir irgendwann RAM, den kodi für andere Sachen gerne nutzen würde.
    Mit readbufferfactor = 3 oder =10 bringst Du Dein Netz auch so richtig "in Wallung" :D gewinnst noch mehr Reserven.

    SaEt9000
  • @SaEt9000

    Jup völlig richtig, das wäre der nächste Parameter gewesen ;)

    Danke für die Erläuterung.

    Gruss Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Nvidia Shield, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • sehr gute Frage....


    oder eher eine Frage der Philosophie oder des Ansatzes.

    Kodi holt per se genau so viele Daten, wie es eigentlich benötigt.
    Holt es mehr - dann verstopft es Dir im Prinzip unnötig Dein LAN mit großen Datenpaketen. Je knaper dann die Bandbreite, je mhr Störungen hast Du dann evtl an anderer Stelle.

    Das Gleiche gilt ja auch mit dem Pufferspeicher. Eigentlich sollte es reichen - brauchts Du mehr, dann fehlt der RAM evtl. an anderer Stelle.

    SaEt9000