Kodi Datenbank gemeinsam nutzen (zentral auf dem NAS)

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

  • Ich habe die Erfahrung gemacht, dass die dort abgelegten Settings der Addons zwischen unterschiedlicher
    Hardware nicht kompatibel sind. Das fängt schon bei der Screengröße an. Um Probleme im Vorfeld zu
    vermeiden, habe ich diesen Block entfernt.
    Dir steht es natürlich frei, ihn wieder bei dir einzufügen und es zu testen.
    zidoo X9S · amazon fireTV Stick · Panasonic TX-P46GW20 · Synology DS216j und DS215j · MacBook Air · FritzBox 7590
    Die richtige Formulierung eines Problems ist nicht selten bereits die halbe Lösung.
  • Hi Sprengbox,
    danke für die Info! Ich werd´s mal mit der neuen Version probieren, falls ich Probleme sehe melde ich mich.
    MfG
    Reelyator

    Homecinema: Marantz SR7011 + MM7025 // UHD: Cambridge Audio CXUHD // Streamer: Cambridge Audio Azur 851N // Lautsprecher: Dali HELICON MKII in 7.1.4 Konfiguration // Beamer: Panasonic PT-AE3000 // TV: Panasonic TX-58DXW904 // Synology DS3617xs NAS
  • Hallo,

    alle Versuche meine Kodi Datenbank zu zentralisieren, sind bisher gescheitert.
    Host Rechner ist ein Windows 10 PC mit dem Filme und Serien in eine MySQL Datenbank (Synology NAS) übertragen wurden. Darüber hinaus wurde ein NAS-Ordner angelegt, in den die Dateien 'source.xml', mediasource.xml' und die Ordner 'playlist' und 'thumbnails' kopiert wurden. Die Datei 'advancedsettings.xml' befindet sich im entsprechenden 'userdata'-Verzeichnis.
    Alles funktioniert einwandfrei auf dem Host-Rechner.
    Anschließend die Datei 'advancedsettings.xml' auf den himedia q5pro übertragen und Kodi gestartet (Version 18.2 auf allen Geräten).
    Filme und Serien sind als Eintrag in der entsprechenden Rubrik zu sehen aber nicht startbar. Außerdem fehlen Fanarts, Poster und Banner.

    Ich gehe davon aus, dass der himedia Probleme mit dem SMB-Zugriff hat, da sich Quellen im dezentralen Betrieb bei diesem Gerät ausschließlich über NFS-Zugriff einbinden lassen. Bei dem Versuch einen SMB-Server in diesem Zusammenhang zu wählen wird mit der Meldung "Operation not permitted" quittiert.

    Ich weiß nicht, ob es relevant ist, aber der SAMBA Service in den Android Einstellungen des himedia ist aktiviert.

    Ich hoffe, jemand unter den Profis kann das Problem lösen.
    Dateien
    • advancedsettings.xml

      (1,07 kB, 4 mal heruntergeladen, zuletzt: )
    • sources.xml

      (821 Byte, 3 mal heruntergeladen, zuletzt: )
    • mediasources.xml

      (137 Byte, 4 mal heruntergeladen, zuletzt: )
  • Das ganze muss in der advanced lauten:
    smb://Passwort (wenns geht dein Admin Konto der NAS, oder vergleichbares mit Admin Rechten) )@192.168.178..../xmbc/thumbnails
    das gleiche für Sources,Mediasources +playlists

    Viel Glück...

    Pansonic TX 58DXX789,HiMedia Q10 Pro + 9x8 TB WD + Int. 8 TB WD Script @messer, CFW 2.0.7 by @moere22
    AVR: Yamaha RX V 631 Multicast,
    Kodi 18.1 (Leia)
    Synology DS 1618+ mit 6x 8 TB WD RED
    Synology DS 1618+ mit 6x 10 TB WD Ironwolf
  • Danke für die schnelle Antwort.
    Deinen Vorschlag habe ich bereits versucht, leider ohne Erfolg.
    Aber ich habe für den himedia in der 'advancedsettings.xml' für die Verweise auf die Dateien 'source.xml', mediasource.xml' und die Ordner 'playlist'und 'thumbnails' das NFS- statt des SMB-Protokolls verwendet. Bis auf die Verknüpfung auf den 'Thumbnail' - Ordner funktioniert alles, sogar gesehene Medien sind korrekt markiert.
    Damit fehlen jetzt noch die Fanarts, Poster und Banner.
    Wer kann helfen?
  • $mo$ schrieb:

    Damit fehlen jetzt noch die Fanarts, Poster und Banner.
    Wenn die Filme auf dem Win10 Rechner liegen und die Fanarts, Poster etc. auf dem NAS, dann wureden hier sicherlich auch die Berechtigungen gesetzt, oder , d.h. NFS Berechtigung auf die Ordner für den Himedia. (lesen/Schreiben)

    Lony
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED
  • Das ganze auslagern von dem Thumbnail Ordner würde ich jedem der nicht genug Speicherplatz auf externen Laufwerken hat empfehlen.
    Allen anderen rate ich zum TMM. Saubere Sache alles liegt bei den div. Filmen. Es muss die Datenbank nicht gesäubert werden etc.
    Ein ganz tolles Programm, und die 3.0er sowieso. :thumbup:

    Pansonic TX 58DXX789,HiMedia Q10 Pro + 9x8 TB WD + Int. 8 TB WD Script @messer, CFW 2.0.7 by @moere22
    AVR: Yamaha RX V 631 Multicast,
    Kodi 18.1 (Leia)
    Synology DS 1618+ mit 6x 8 TB WD RED
    Synology DS 1618+ mit 6x 10 TB WD Ironwolf
  • Filme und Serien liegen auf einem NAS.
    Mittlerweile muss ich davon ausgehen, dass es sich bei meinem Problem um ein himedia spezifisches Problem handelt. Ich habe gestern einen z99 Mediaplayer auf Android Basis in Betrieb genommen.
    Ich habe Kodi installiert, einmal gestartet, das Verzeichnis "org.xbmc.kodi" gelöscht und diesen Ordner 1:1 vom himedia (einschließlich der Datei "advancedsettings.xml") übertragen. Der anschließende Start von Kodi auf dem Z99 offenbarte eine fehlerfreie Funktion mit der zentralisierten Datenbank, einschließlich aller Fanarts, Posters und Banners.

    Mein Frage ist nun, ob jemand eine zentalisierte Datenbank mit Thumbnails zum Laufen bekommen hat.
  • Also da es sich um den Zidoo um eine ganz andere Hardware (MAC Adresse) handelt, würde ich Kodi komplett neu installieren.
    Danach die Dateien kopieren und versuchen.
    Alles andere kann ich von meinen Hochsitz nicht sehen.

    Pansonic TX 58DXX789,HiMedia Q10 Pro + 9x8 TB WD + Int. 8 TB WD Script @messer, CFW 2.0.7 by @moere22
    AVR: Yamaha RX V 631 Multicast,
    Kodi 18.1 (Leia)
    Synology DS 1618+ mit 6x 8 TB WD RED
    Synology DS 1618+ mit 6x 10 TB WD Ironwolf
  • zusammen schrieb:

    Also da es sich um den Zidoo um eine ganz andere Hardware
    Zidoo ???
    Mediaplayer: EWEAT R9_Plus, ZIDOO X9s, Himedia Q10-Pro
    TV :Sony KD-75XD9405, SONY KDL 52LX905
    SAT-Receiver: Vu+ Uno 4K SE mit VTi 13.0.10
    AVR Denon X4200W
    SOUNDSYSTEM :Teufel System 6 THX 5.2.2
    NAS: (Synology) DS112+ -1 x 2TB WD Green, DS414J - 4 x 4TB WD RED, DS415+ - 4 x 3TB WD RED
    , DS216Play - 2 x 2TB WD RED